gear change and revs gone mad help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-10-2010, 05:20 AM Thread Starter
BenzWorld Extremist
 
Date registered: Sep 2004
Vehicle: SL320 1999 WDB 129064 2F 177672 7 ENGINE 112943 30 333401 GEARBOX- 722607 0 1207121
Location: Cork Ireland
Posts: 899
Mentioned: 0 Post(s)
Quoted: 41 Post(s)
(Thread Starter)
Question gear change and revs gone mad help

gear shift revs gone mad help
I hadn't driven my car for 6 days - put the accelerator to engage kick-down to over-take a truck and the car jolted violently like something was stopping it accelerating through the gears- the rev counter worked ok when driving around 40 but seemed to want to stay at 2000rpm and if i pushed the revs to 2500rpm it would jolt violently. Then in P it revs to a limit of 4000rpm and cuts out consistently when it should go to the red when it hits 6000rpm and cut out. So maybe it is not a gear change issue- or maybe something is being denied to the gearbox and then it jolts into position-maybe some electrical message is not getting to the gear box or is the car being denied air at the right time???????????
Any chance of some ideas as it will be a while before i can get my mechanic to look at it-

I now don't trust my car to pass a truck without endangering me but i will persevere
this car has been very well taken care of throughout its 89000 miles
i have a constant rough idle when stationary and sporadic puffs of white smoke (running lean) which i can't source in case that has relevance

work done -
gear box rebuilt fully and properly
plugs htleads fuel filter air filters oil oil filter MAF crank position sensor throttle body cleaned valve cover gaskets


Thank you for any ideas
regards
darragh
darraghodonnell is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-10-2010, 07:57 AM
BenzWorld Elite
 
Date registered: Feb 2008
Vehicle: 2004 W220 (S430) ; 2001 R129 (SL500) Sport
Location: Alabama Gulf Coast--formerly Charlottesville, VA
Posts: 1,335
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If it were a V-8 version, I'd say it was a crank position sensor. I don't know the 6 cylinder versions well enough to say that with confidence. The rough idle may indicate MAF troubles either as well or as the sole cause of the problems. I'd suggest you take it to a place that can read the codes from the OBD II port. Perhaps that will tell you exactly what the problem is.

Sorry I can't be more confident or specific.

Cheers.

"Don't pick a fight with an old man. If he is too old to fight, he'll just kill you."--John Steinbeck
DrJfrmLA is offline  
post #3 of 4 (permalink) Old 04-10-2010, 08:45 PM Thread Starter
BenzWorld Extremist
 
Date registered: Sep 2004
Vehicle: SL320 1999 WDB 129064 2F 177672 7 ENGINE 112943 30 333401 GEARBOX- 722607 0 1207121
Location: Cork Ireland
Posts: 899
Mentioned: 0 Post(s)
Quoted: 41 Post(s)
(Thread Starter)
thank you drJ-
new cps and MAF recently
i'll just have to wait for my mechanic to read codes
if you think of anything else let me know
regards
darragh
darraghodonnell is offline  
post #4 of 4 (permalink) Old 04-12-2010, 04:26 PM Thread Starter
BenzWorld Extremist
 
Date registered: Sep 2004
Vehicle: SL320 1999 WDB 129064 2F 177672 7 ENGINE 112943 30 333401 GEARBOX- 722607 0 1207121
Location: Cork Ireland
Posts: 899
Mentioned: 0 Post(s)
Quoted: 41 Post(s)
(Thread Starter)
No codes were thrown by the star machine today- my mechanic will look at it wednesday again and i'll get back, thanks,

Darragh
darraghodonnell is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    gear shift revs gone mad help darraghodonnell R129 SL-Class 4 04-13-2010 08:53 PM
    Engine revs up in 1st gear Electra7 W210 E-Class 3 12-08-2009 12:16 PM
    M104 engine revs fine except when in gear kboutorabi W124 E,CE,D,TD Class 2 07-22-2007 09:14 PM
    1st gear revs high Panther201 W201 190-Class 3 03-29-2006 06:17 PM
    High revs for 1st gear when engine cold redzer007 W124 E,CE,D,TD Class 3 12-07-2004 01:39 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome