94-C280 No Start Problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-30-2010, 07:36 PM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2009
Vehicle: C280 1994
Location: Wichita, Kansas
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 94-C280 No Start Problem

Car drove fine, parked in the garage after work, and next morning, engine
cranked as usual but no start. Giving it more gas, almost got it to start, but no go. First guess is bad fuel pump? Or fuel filter? Ideas? Is this a DIY or a difficult one that needs to go to the repair shop. Short on cash, but got to have the car. thanks for answers.
dreynolds36 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    95 C280 won't start silver95c280 W202 C-Class 9 07-23-2009 11:58 AM
    How do I get my wrecked C280 to start? shawntitan W202 C-Class 1 04-22-2009 04:25 PM
    98 C280 Start Problem - Engine dies after 1st crank W202SF W202 C-Class 3 10-31-2008 07:47 AM
    96 C280 will not start merc280 General Mercedes-Benz 1 10-15-2007 05:49 AM
    94 C280 won't start pguard W202 C-Class 9 12-28-2006 04:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome