1981 D not Accelerating... - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-30-2010, 07:31 PM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2010
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1981 D not Accelerating...

My 1981 300D will not accelerate. Engine mounts need to be replaced because they started rocking recently. When driving today all acceleration has ceased. There has been a clicking noise since I ran out of gas 3 days ago.
When I push the accelerator the engine does not rev up.
Any ideas on what it might be?
dallasmike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Not Accelerating Well Going Up Hill shazanger W123 E,CE,D,CD,TD,TE Class 15 12-13-2009 04:02 PM
    need help with 1981 200 hesitation while accelerating mckee79 W123 E,CE,D,CD,TD,TE Class 0 09-08-2009 07:55 AM
    94 E320 not accelerating 94dawgfan W124 E,CE,D,TD Class 19 01-05-2009 01:56 PM
    Swaying when accelerating Guest (MBNZ) W201 190-Class 2 11-09-2001 10:12 AM
    Accelerating problems Guest (MBNZ) W210 E50 AMG, E55 AMG 7 07-16-2001 01:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome