S500 Wiper Issue - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-24-2010, 10:31 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 2000 ML320 + 1997 S500
Location: Massachusetts
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S500 Wiper Issue

Hi.

The passenger side wiper arm on my S500 got stuck in up position and did not move. I checked the nut holding on the arm and it was a bit lose so tightened it up...wiper starting moving for about 10 cycles and then stopped again.

Checked and the motor and it is turning fine. Seems like the arm and mount are stripped (no grip) on the arm. My question is, do I need to replace the arm or has anyone else have a different solution...like I said the motor is working.

Thanks.
Benz14.
benz14 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Wiper issue - Need advice infra R129 SL-Class 40 12-08-2010 06:11 PM
Wiper Transmission Issue bujjodu W202 C-Class 0 01-30-2010 03:26 PM
Need help w/windshield wiper issue speakerdude W163 M-Class 5 11-26-2009 03:16 AM
Wiper replacement issue hawkrider W202 C-Class 1 04-07-2009 08:07 PM
WIper Fluid Issue malbence R/C107 SL/SLC Class 21 09-07-2008 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome