motor blower problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-20-2010, 01:47 PM Thread Starter
BenzWorld Newbie
Date registered: Mar 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
motor blower problem

just installed a regulator for my 97 e320 and now blows out hot air on ac when I tried to put coolent it registers that i may have problems do I have to reset anything? thanks
bkosar is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-2010, 02:32 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
FYI: You have what MB calls a W210, please join us there; just scroll down to the sedans section and look for us.

I don't think any reset is required after that replacemrnt. How did it register that you might have problems? If it's possible on your 1997 run the climate control diagnostics (steps are in the DIY stickys at top of the W210 pages) and post the results here including any error codes. If you don't there might be other helpful info in the CC sticky section.

Good luck and welcome to the forum.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Blower Motor Problem hornet99 W220 S-Class 7 02-03-2010 06:28 PM
    Blower Motor problem MorrisTigerson69 W126 S,SE,SEC,SEL,SD,SDL Class 16 12-27-2006 07:46 AM
    I have a problem with the heater blower motor.............. Bruce R. W201 190-Class 6 10-19-2006 07:26 AM
    Blower motor problem ralfnader W201 190-Class 3 12-29-2005 11:55 AM
    300D a/c blower motor problem GA81MB W123 E,CE,D,CD,TD,TE Class 1 04-18-2005 02:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome