95 C280 woes - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-19-2010, 11:46 AM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2010
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
95 C280 woes

(i thought I would move this from the Sedan forum)

Hello all, this forum has been a help to a lot of the problems I've had, but lately I think I need to ask for some help directly (hopefully this is the right place).

The main problem I am having now is the wiper is not working. The fuse blows whenever the motor is plugged in and the car is turned on. Just to clarify; unplugging the motor and then starting the car does no harm to the fuse. Strangely the motor itself is functioning properly, as it was tested with an alternate power source. I have read that a stripped gear is a common problem with these wipers, but when the motor was checked the wiper moved properly. The problem started when the wipers were started while there was some snow/ice blocking the wiper's path.

I am also having a problem with speedometer and other meters not moving sometimes, which I have read can be fixed by removing some paint of the pins?

I also find that car needs to jump a little bit when accelerating from zero, which seems to be a common problem with this car. As well as needing to put significant pressure on the gas pedal to reverse at a reasonable speed.

Lastly, I hear strange noises near the back left tire when a relatively hard and fast turn. It sounds like some sort of dangerous clanking, or maybe like something heavy and loose is being flung around in the trunk, but alas that is not the case. I've even once managed to replicate the sound simply by shaking the car up and down while it was parked.

Thanks in advance for anyone who might be of help!
miharbio is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1995 C280 woes miharbio W202 C-Class 11 04-09-2010 09:10 AM
    C280 woes Kabanimotorsports.com General Mercedes-Benz 2 02-18-2010 07:09 PM
    Difference in feel between the 1997 C280 and 1999 C280 SechsPackSound W202 C-Class 3 04-18-2006 05:48 PM
    woes of a brand new c280 4matic...doa johnrmcc W203 C-Class 2 11-15-2005 03:26 PM
    **C280 Experts: Opinions on this C280?? schranz W202 C-Class 0 05-31-2004 03:15 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome