antenna doesn't go up after replacing Becker deck - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-13-2010, 09:23 AM Thread Starter
BenzWorld Newbie
Date registered: Mar 2010
Vehicle: 1981 300SD Turbo Diesel
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
antenna doesn't go up after replacing Becker deck

I just bought a 1981 300SD from a kid on here, and I must say, WOW! These things are built so well! It starts up every time, there are some minor cosmetic problems with the interior, but the clear coat on the outside is almost pristine. There is one small spot near the tail light where it's just starting to come up, but other than that.

So anyway, the LCD was shot on the Becker stereo deck that was in it already, and so I found this forum looking for a wiring guide. I ended up just testing with a voltmeter. I got all it all hooked up, but now the antenna won't come up, and the light for it on the instrument panel is out. I checked all the fuses and everything is making contact. Does the radio somehow control the antenna, or is this just coincidence?

Also, the left driver's side seat will not move or tilt or anything, and the sunroof crawls when you try to put it back. I noticed that the roof slopes down on the inside, and it looks like it's rubbing after the sunroof about 1/3 or so back. If you push on it, it will move up with you, but it goes back down when you let go. It feels like there's a thin piece of metal under the vinyl material; that is what bows and moves and you can hear it when you press it.
Leonicdragon is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-13-2010, 11:01 AM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1999 S420 - replacing radio deck AK-S420 Audio & Telematics Forum 9 08-21-2009 01:10 PM
    Wanted: Operational Becker radio tape deck to give away WeVonBraun For Sale/Wanted/Trade/Giveaway 3 07-25-2007 03:32 PM
    replacing tape deck '86 300E paulb W124 E,CE,D,TD Class 3 05-18-2007 07:48 AM
    antenna wont work with new deck!! AHHH crazypolok W124 E,CE,D,TD Class 3 03-17-2006 07:26 PM
    antenna not working with new deck? crazypolok Audio & Telematics Forum 0 03-13-2006 09:58 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome