722.9 7-speed transmission problem. - Page 7 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#61 (permalink) Old 05-14-2010, 06:25 AM
BenzWorld Junior Member
 
Date registered: Feb 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
strangest thing is that the problem occurred 5-6k miles when I change the ATF - strange coincedence..........
mrluigi is offline  
Sponsored Links
Advertisement
 
#62 (permalink) Old 05-14-2010, 06:28 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,432
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by mrluigi View Post
okay. i will do SDS as soon as possible.

what could it be? probably torque converter or shortage of ATF?
before i bought the car - second hand from official dealer at low miles, was asking god help me to find one which will be without problem on that sticky torque converter, but most probably god has missed to give me the right one ((
The normal cause is the control unit but this means the valve body has to be changed also as they are sold as one unit. But do not panic just yet and have the tests run first, then panic lol.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#63 (permalink) Old 05-14-2010, 06:30 AM
BenzWorld Junior Member
 
Date registered: Feb 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by eric242340 View Post
The normal cause is the control unit but this means the valve body has to be changed also as they are sold as one unit. But do not panic just yet and have the tests run first, then panic lol.
talk me in $$$ plssssss

and can i drive car in C-mode with problem exists or I have ot make repair in any case s

pleease sir help here thanx
mrluigi is offline  
#64 (permalink) Old 05-14-2010, 06:35 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,432
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by mrluigi View Post
talk me in $$$ plssssss

and can i drive car in C-mode with problem exists or I have ot make repair in any case s

pleease sir help here thanx
Sorry as I do not work in America I cannot say but there are many threads on this subject where costs have been mentioned, do a search on the 722.9 transmission.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#65 (permalink) Old 05-20-2010, 03:28 PM
BenzWorld Junior Member
 
Date registered: Mar 2010
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i too have this problem on my 04 E500.. but sometimes it happens once a week or every 2 weeks. I recently bought the car at 58k miles... I'm not sure if the previous owner has change the ATF. I probably will do ATF change to eliminate the possibility but I have my mechanic check the error code and it also showed: The signal from component Y3/8n1 (Turbine speed sensor (VGS)) is not available.

I only have the car for around a month, I'm not ready to replace the valve body
violato is offline  
#66 (permalink) Old 05-20-2010, 07:58 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,432
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by violato View Post
i too have this problem on my 04 E500.. but sometimes it happens once a week or every 2 weeks. I recently bought the car at 58k miles... I'm not sure if the previous owner has change the ATF. I probably will do ATF change to eliminate the possibility but I have my mechanic check the error code and it also showed: The signal from component Y3/8n1 (Turbine speed sensor (VGS)) is not available.

I only have the car for around a month, I'm not ready to replace the valve body

When was the fluid changed last?

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#67 (permalink) Old 05-21-2010, 01:00 PM
BenzWorld Junior Member
 
Date registered: Mar 2010
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
not sure.. i just got this car... I believe the previous owner never changed the transmission fluid before... do you think it will help?
violato is offline  
#68 (permalink) Old 05-21-2010, 07:48 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,432
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by violato View Post
not sure.. i just got this car... I believe the previous owner never changed the transmission fluid before... do you think it will help?
We normally do this as a first step, if that fails then its the valve body.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#69 (permalink) Old 05-24-2010, 10:11 AM
BenzWorld Junior Member
 
Date registered: Mar 2010
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by eric242340 View Post
We normally do this as a first step, if that fails then its the valve body.
thanks for the reply Eric. I'll try to do this first although my mechanic says it most likely the valve body because that's what the error code says and the speed sensor is using magnetic not pressurize...

The other thing is, according to the MB dealer, the valve body is "married" to the transmission and can only be programmed once so I cannot buy a used one but my mechanic says he has a friend that can reflash / reprogrammed valve body that comes from other transmission and make it work with my transmission. I really hope the latter is true.
violato is offline  
#70 (permalink) Old 05-24-2010, 10:17 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,432
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 36 Post(s)
Quote:
Originally Posted by violato View Post
thanks for the reply Eric. I'll try to do this first although my mechanic says it most likely the valve body because that's what the error code says and the speed sensor is using magnetic not pressurize...

The other thing is, according to the MB dealer, the valve body is "married" to the transmission and can only be programmed once so I cannot buy a used one but my mechanic says he has a friend that can reflash / reprogrammed valve body that comes from other transmission and make it work with my transmission. I really hope the latter is true.
I find the latter hard to believe. But I would not go so far as to say impossible.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
722.6 transmission RPM sensor problem AceCal W210 E-Class 44 09-05-2014 01:24 PM
DIY Mercedes 722.3 722.4 722.5 Transmission K1 Piston Spring Repair Kit Install HATTENATOR W201 190 Class 83 10-27-2010 12:19 PM
1995 600SL w/ 722.3 four-speed trans fluid problem Rudi Raaths R129 SL Class 3 01-30-2009 11:32 PM
atlanta Mercedes 722.603 transmission - auto 5 speed - $650 atlantas420 W140 S-Class 0 10-02-2008 10:32 AM
is transmission problem?! 722.4 or 722.1 ?! kiwiya2001 W123 E,CE,D,CD,TD,TE Class 13 10-07-2005 11:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome