R170 ROOF PROBLEM - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-05-2010, 04:27 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
R170 ROOF PROBLEM

Hi All,

I wondered if anyone here knows how to replace the top switch on my R170, I’ve tried searching the forums and can’t seem to find anything despite people giving suggested search strings. Just to give you some back ground the small rear windows would not go back up after the roof locks back into place. I think I know what the problem is as I managed to get them to go back up by grounding pin 30 in the control box whilst putting the roof back up. I found the temp solution in a thread on here. So this leads me to believe it’s the switch above the wind screen. Does anyone know how to get at it to replace it? Anyones help would be very much appreciated and thanks.

Matt
matt1980 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-05-2010, 05:26 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Search the R170 forum for postings by "Bazzle". That should narrow things down quite a bit.

Mike
Michael Pillay is offline  
post #3 of 6 (permalink) Old 03-05-2010, 08:03 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
This might help. Have you posted your question on the R170 forum?

http://www.benzworld.org/forums/r170...ario-roof.html

Mike
Michael Pillay is offline  
post #4 of 6 (permalink) Old 03-13-2010, 08:49 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Right I've had a good read of bazzle's posts I've tried grounding pin 30 in the control box and the windows go back up. Then I tried grounding the circuit at the switches and nothing happens. I've tested the switches and both of them work. Also when I drive the car the roof light flashes and the warning gong sounds. Does anyone have any other ideas your help is much appreciated.

Matt
matt1980 is offline  
post #5 of 6 (permalink) Old 03-13-2010, 12:34 PM
BenzWorld Elite
 
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Get the service CD

Star Service CDs and DVDs

Kent Christensen
Albuquerque
'07 GL320CDI
lkchris is offline  
post #6 of 6 (permalink) Old 03-13-2010, 12:36 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by Michael Pillay View Post
This might help. Have you posted your question on the R170 forum?

http://www.benzworld.org/forums/r170...ario-roof.html
Matt,
in the above link scroll down to "Vario roof diagnostics & troubleshooting guide" that should help narrow it down.
also heres a helpful link Top Operation
there's a few more links in my signature.
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    R170 Roof problem, trunk doesn`t open BoBKa R170 SLK-Class 5 06-30-2009 05:36 AM
    SLK R170 Headlamp washer problem justin.glover1 R170 SLK-Class 8 05-26-2009 10:14 AM
    R170 top problem dumokie R170 SLK-Class 0 09-25-2008 04:25 PM
    R170 cable loom near roof pump chafing tl99999 R170 SLK-Class 1 12-29-2007 07:33 AM
    r170 '99 Roof Problem, again! CLK320s R170 SLK-Class 1 04-30-2007 08:51 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome