Silence - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-26-2010, 01:06 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Silence

Hi all. I have 04 180 C Class. Every now and then the radio cut out and then would come back on after 5 or so minutes on its own.
The other day it went off and now wont come back on at all.
Cant find the fuse layout so I dont know which fuse it it. I actually checked everyone and found that they all seemed fine.
Question 1...Does anyone know which fuse is it and question 2....Any other ideas what it could be?

You really need to help as i can only stand so much of the wifes singing
panlid is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-26-2010, 07:36 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I think a fuse is either good or bad. Does it at least light up when you cannot hear it playing? If so chances are it's something else like the volume control knob so try cleaning it with contact cleaner. If not, I would look for a loose or corroded wire connection. You'll probably have to pull it out to check for that.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 02-27-2010, 01:32 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi Musikman.
No, doesnt even light up. Any idea how i would take it out?
panlid is offline  
post #4 of 4 (permalink) Old 02-27-2010, 06:32 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Hi too and sort of. There are hooks you can buy (radio or head unit removal tools) for this purpose but some members have made their own. As I recall they are not expensive; the dealers sell them and some have found them on eBay. To me it sounds like the power supply wire(s) to it is to blame.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Silence of the Hams mcbear Off-Topic 4 05-05-2009 05:00 PM
    Silence of the board mlfun Off-Topic 8 10-10-2008 07:13 AM
    ...and then there was silence smack R/C107 SL/SLC Class 10 06-13-2008 09:27 PM
    A minutes silence please... stingray.au W163 M-Class 0 04-22-2003 05:28 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome