W126 Air Conditioner Faulty - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-21-2010, 08:23 AM Thread Starter
BenzWorld Newbie
SCHENK X's Avatar
Date registered: Feb 2010
Vehicle: Mercedes Benz 300se W126
Location: Malaysia
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool W126 Air Conditioner Faulty


I am new to this site and new to this car, I have a W126 300se 1988 , The problem is that the haeter stays on , in Malaysia we have no need for a heater all i need is cool air all the time , I have tried disconnecting the water supply to the heater but the only difference is that the air is not hot , The A/C isnt seem to be blowing cold at all. I have taken it to the garage (A normal A/C shop which repair mostly Japanese cars ) and they told me there is nothing wrong with my compressor, I have read some where about MOnovale , what does this do and where is it ? Or does this A/C work with any of the vacuum hose ? This is really making me have sleepless nights Somebody Please Help !
SCHENK X is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Air conditioner does not go off Orinoco W140 S-Class 7 05-13-2013 06:22 AM
    Air Conditioner does what it wants.... Eugene 87 300 TDT W124 E,CE,D,TD Class 0 08-17-2005 02:37 PM
    air conditioner stopped blowing cold air 86 420 sel W126 S,SE,SEC,SEL,SD,SDL Class 10 07-20-2004 11:26 AM
    Air conditioner not blowing cool air 400SEL W140 S-Class 2 07-13-2003 01:07 PM
    AIr Conditioner Guest (MBNZ) General Mercedes-Benz 1 04-02-2001 02:27 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome