1989 190e 2.6 check engine lite/power loss - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-15-2010, 06:14 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2010
Vehicle: 1989 190E 2.6 MB sedan 140,000K
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1989 190e 2.6 check engine lite/power loss

My car starts well, but after running for various lengths of time, the check engine lite comes on, followed by a brief revving, and then near stalling. After time it will eventually stall. Can happen after 1/2 hour, or 10 minutes. Restarting is difficult. If the car is put in neutral and I step on the gas to keep the RPMs up, it wont stall. It seems worse when the engine is warm
The onboard computer is good- was checked professionally- and the relay overload was replaced. Have not taken it in to have the computer codes checked. (trying to keep costs down)
What's the next step? Any idea what the problem could be?
PS neighbor ex MB mechanic is stymied too!
hydramom is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-15-2010, 06:10 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    need help please power loss (bogg) on 1989 260e medi W124 E,CE,D,TD Class 1 09-15-2008 04:47 AM
    Engine check Lite Quesion bearone2 R129 SL-Class 0 04-15-2008 01:00 PM
    Intermittent Check Engine light and power loss benzer04 W126 S,SE,SEC,SEL,SD,SDL Class 2 07-16-2004 10:47 AM
    Power Loss 190 E 2.6 1989 barrem W201 190-Class 2 03-16-2004 11:03 AM
    check engine lite gR8jBenZ W124 E,CE,D,TD Class 2 01-04-2004 01:39 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome