Technical question RE: CLS 500 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-14-2010, 06:14 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Technical question RE: CLS 500

2006 CLS 500, great car and very few, if any, problems. However, I now have a blown fuse that controls all of the buttons, functions on the steering wheel (phone answer/hang up, volume control, instrument panel scroll for messages, etc.). I have changed the fuse twice, each time solving the problem. After about 24 hours each time the fuse goes out again so there is something causing this to happen. Please advise if anyone has had this problem. Thanks in advance to all!
ajcollier is offline  
Sponsored Links
post #2 of 4 (permalink) Old 02-08-2011, 12:05 PM
BenzWorld Junior Member
Date registered: Jan 2011
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)


Which Fuse was it? Number would be great I have the same issue!
Mercedes_CLS is offline  
post #3 of 4 (permalink) Old 02-08-2011, 12:32 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Both of you guys need to find the CLS-Class forum. Just scroll down from this general one until you see it. BTW, welcome to BenzWorld!

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 4 (permalink) Old 02-09-2011, 11:58 AM
Outstanding Contributor
keyhole's Avatar
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,359
Mentioned: 9 Post(s)
Quoted: 343 Post(s)
Since the thread is here, I'll add something - but why do you newbies post in the first forum you find!

All the steering wheel button signals are fed to the steering column control module (N80) which is fused by f29 (7.5A). This fuse is located in fusebox F34, the interior fusebox. The external lamp switch (S1) also uses this fuse.

What are you doing when the fuse blows? If nothing, there must be an intermittent shorted wire somewhere....
keyhole is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    cls 63 body kit on a cls 500 amalik9898 General Mercedes-Benz 1 02-03-2008 02:07 AM
    MB CLS Technical Information Source a1certified C219 CLS-Class 1 07-27-2007 09:23 AM
    cls 500 question on adding keyless go and parktronic to plain cls? REDCLS55 C219 CLS-Class 1 07-21-2007 10:20 PM
    CLS 55 and CLS 500/550 body style newguycls55 C219 CLS-Class 4 05-23-2007 10:30 AM
    Technical Data of W140 500 SEL Great W140 S-Class 3 07-12-2003 08:08 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome