ML 320 2000 starting problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-13-2010, 07:45 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2009
Posts: 51
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML 320 2000 starting problems

Hi i have a ML 320 2000 and today when i driving to my home in the midle of road it turn off and i have to park inmediatly. when i tried to star it cranks but not start so i call a tow truck to take me home. Maybe a month ago it did a similar problem i drive for a while ann then when i park a left abot 1 or 2 hours it cranks but not start then i check the fuel pressure and no have any pressure. I change the fuel pump and also the spark plug and it runs very fine for 3 weeks until now. Another problem when i drive suddenly it apply the break with no reason and turn on the BAS ESP Light also i change the brake light switch but does the same problem again. Someone that help me please. Thank You
mecdiesel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-14-2010, 05:31 AM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Any fault codes? Especially relating to the crankshaft position sensor, for example?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 5 (permalink) Old 02-14-2010, 11:55 AM Thread Starter
BenzWorld Member
 
Date registered: Nov 2009
Posts: 51
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no i check with a scanner and no codes retrieve iam frustate because it have fuel pressure but i dont know what it is how i know if the CPS are bad???
mecdiesel is offline  
post #4 of 5 (permalink) Old 02-14-2010, 06:51 PM Thread Starter
BenzWorld Member
 
Date registered: Nov 2009
Posts: 51
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Please someone help me
mecdiesel is offline  
post #5 of 5 (permalink) Old 02-14-2010, 09:28 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Since you changed the fuel pump (a known weakness in the chassis) with those symptoms I'd go with the crank position sensor. Inexpensive part and easy enough to DIY, it typically does not throw codes when it fails.

FWIW, you're much more likely to get specific help if ypu post in the W163 forum, which focuses on your chassis.

Good luck, see you in the 163 forum.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ML 320 2000 brake problems mecdiesel W163 M-Class 1 02-05-2010 04:57 PM
    ML 320 fuel problems and starting mecdiesel W163 M-Class 2 01-18-2010 07:18 AM
    2000 ML 320 Problems kboogie668 W163 M-Class 12 08-17-2008 09:36 AM
    2000 ML 320 problems Simon W163 M-Class 8 05-06-2002 02:21 PM
    2000 SLK 320 auto-transmission problems and more heather R170 SLK-Class 5 10-20-2001 01:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome