Heater Won't Switch from Defrost to Floor - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-13-2010, 01:03 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2010
Vehicle: 82 Mercedes 300-TDT
Location: Atlanta, GA
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Heater Won't Switch from Defrost to Floor

I have an 85 300DT and while the defroster on the car works fine (I just changed the blower/motor), I have never been able to use the console switches to change from defrost setting to the floor. Regardless of the switch I choose, it remains fixedly on defrost setting.

Is there an easy fix for this so we don't have to drive with frozen toes?

Last edited by danashields; 02-13-2010 at 01:12 PM. Reason: clarification
danashields is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-13-2010, 02:27 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,776
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
Sounds like your vacuum controls are not operating and the system defaults to defrost.
The vacuum connectors in the oil filter area are the most common problem.
Kajtek1 is online now  
post #3 of 6 (permalink) Old 02-13-2010, 03:15 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2010
Vehicle: 82 Mercedes 300-TDT
Location: Atlanta, GA
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Heater Stuck on Defrost

I take it that since I combed through the vacuum lines around the filter and that they all look good, the same could hold true for any lines that go through the firewall, correct?

If so, I'll remove the under dash panel tomorrow to give it a look-see.
danashields is offline  
post #4 of 6 (permalink) Old 02-13-2010, 04:20 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,776
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
Go to W123 section for more info how to deal with those pesky vacuum lines.
At some age they cost lot of troubles. Is you engine shutting off OK?
I wouldn't rush into opening the dashboard before double checking the easy stuff.
Kajtek1 is online now  
post #5 of 6 (permalink) Old 02-14-2010, 06:05 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2010
Vehicle: 82 Mercedes 300-TDT
Location: Atlanta, GA
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vacuum Lines

Engine shuts off fine. But vacuum lines don't work for door locks either. I was under the panel a couple of years ago to install something, so it's possible that it was I who was the bonehead who jarred something loose under the dash.

I will take some time to look under the W123 topic. I didn't see a page devoted to W123 on the forum's main menu, but I'll keep hunting around. (Hopefully I won't jar anything loose in my quest to find it.)

Last edited by danashields; 02-14-2010 at 06:05 AM. Reason: clarify
danashields is offline  
post #6 of 6 (permalink) Old 02-14-2010, 10:41 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Look in the sedans section for W123. If your locks aren't working that might point to the PSE pump. Locate that and check the tubes coming from it.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Very weak defrost and floor heat! ksing44 W124 E,CE,D,TD Class 15 12-14-2008 01:33 PM
    Defrost & Heater: Any Problems? LGV W221 S-Class 4 11-11-2008 06:15 PM
    ashtray and defrost switch mercbuff W140 S-Class 0 07-16-2005 07:40 AM
    2001 C240 HEATER FLOOR HEAT MAX BLAKELY W203 C-Class 0 02-20-2004 06:29 PM
    Climate Control Switches from Floor to Defrost E320Wagon General Mercedes-Benz 1 02-20-2004 01:26 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome