Central Locking Fuse keeps blowing - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-12-2010, 03:20 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Central Locking Fuse keeps blowing

Hi, I have an 02 Sl500 and the central locking fuse is blowing nearly everyday at the moment. I've read posts about the fuse going due to the pump getting wet, but I've checked and my boot is bone dry as is the area where the pumps are located.

Currently this seems to be what happens. I put a new fuse in, test everything, all works fine, boot, doors etc. Lock and Unlock. Open close boot/trunk fine. Get in, drive 20 miles to work, get out, can't open boot, fuse is blown. This has happened two days in a row now. It blew a fuse once last winter, and then about 2 weeks ago this winter which I assumed was due to frost in the seals of the boot or something that was causing excessive strain on the pump. But two fuses in two days and it wasn't even freezing this morning makes me concerned. Wondering if there is any adjustments on the boot or anything? Quite funny as I ran out of 20 amp fuses this morning and put a 15 in and it didn't blow that, it's working fine at the moment. Will have to see how long this one lasts I guess. Going to take it to my local mechanic who deals exclusively with MB and has all the computers for MB - but if anyone has any experience with this or can offer any insite I'd appreciate it.
jogdial is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-14-2010, 12:41 PM
BenzWorld Member
Date registered: Jul 2007
Vehicle: 2003 CLK430A Cabriolet
Location: Raleigh, NC
Posts: 64
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Is it possible you are not putting the right rated fuse in?
nkosi is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2003 SL500 Central locking fuse? pyschopav R230 SL-Class 19 08-08-2015 08:51 PM
    Problem with VITO central locking and air suspension fuse Adrian_86 V-Class 11 01-26-2011 02:07 PM
    Central locking not working fuse blowing!! markyw220 W220 S-Class 1 03-24-2009 12:36 PM
    01 s430 central locking fuse Keeps blowing NEU-BUG W220 S-Class 5 03-28-2008 06:15 AM
    Central locking fuse?? slkdude433 R170 SLK-Class 4 06-26-2006 09:02 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome