A170 CDI "in trouble" - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-09-2010, 01:49 PM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2010
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post A170 CDI "in trouble"

My beloved 2002 A170 CDI Avant Garde started imitating a noisy wagon a few months ago. She then decided she didnt like 1st gear (it felt more like setting off in 4th) once on the road going through gears and at speed she regained normal acceleration and on the motorway in 5th no signs of any problems. Over the last couple of months I started to add a Diesel cleaner when topping my fuel up. For a short spell it seemed to work. I decided to get her looked at and booked her in with a garage (the owner of which had worked for Mercedes for over 20 years) She was attached to a computer which showed number 3 injector was the problem. I left my pride and joy with them almost one week ago. The prognosis was take out the old injector - replace with a new one and (as we say in England) Bob's your Uncle! Sounds great even the cost for the work seemed a small price to pay as I had had her from a 6month old and no problems up to now. The fun started when the garage had to put me off collecting her saying that the injector had seized and they would have to soak it to loosen it. OK I undertand that concept as I am a terrible cook and have to soak most of my pans !! Yesterday (Monday 8/2) "good news old injector out - new injector in BUT - you guessed it still running like a pig...... Never fear blondie we have not given up yet and went on to test the seals on the injector, fuel lines and a lot of head scratching. End result - come and collect your noisy car and we dont have any ideas as to what is causing the noise or why she struggles in higher gears............Great I have spent the last few hours trawling the super high way for any ideas as to what is wrong with her and can it be fixed or should I just plant flowers in her and park on drive as an object of beauty. So come on you experts out there lets see if together we can get my pride and joy back on her feet ................. THANK YOU ALL VERY MUCH FOR YOUR PATIENCE and any help you can give
Aclass Lady is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-09-2010, 02:08 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Since you are new you might not have noticed there is a forum specific to the A-Class cars. Just scroll down from here (General Mercedes-Benz) and look in the sedans section. I don't know that your problem is unique to your type of car, but this forum is hit or miss and the best people to help you, other A-Class owners, might not see your questions here. Good luck and welcome to the forum.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 3 (permalink) Old 02-09-2010, 02:12 PM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2010
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you I am getting a little confused over the different forums, I will try the one you kindly suggested.
Aclass Lady is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    A170 CDI automatic gearbox problem "goes in F mode" manhuwa W168 A-Class 18 01-27-2016 05:20 PM
    Anyone Have More Infomation On This Story? - "250 CDI Diesel into 190 E Chassis!" Zonet W201 190-Class 15 10-06-2009 04:35 PM
    E 320 CDI "BLUETEC"ALL WHEEL DRIVE? scre103 W124 E,CE,D,TD Class 10 01-19-2008 06:09 PM
    Help, my lovely SLK is in trouble... ASR light is on and engine is "bumping".... funfun R170 SLK-Class 10 02-25-2007 03:23 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome