1997 S320 will not start...not happy...please help. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-06-2010, 07:53 AM Thread Starter
BenzWorld Junior Member
Date registered: Jan 2010
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 1997 S320 will not start...not happy...please help.

My S 320 is in a friends body shop for rust removal...a heated garage.
I live in Syracuse, New York, and it is very cold and we have no garage thus the vehicle sits in the elements. I have had no issues with starting even in sub zero weather. I received a call yesterday from the shop..."The car won't start." Mind you these are body people not mechanics. Funny thing is that I received a call the day before asking where the battery was located as with the work being performed they ran down the battery and it needed to be charged....ODD. We popped into the shop last night before they closed and found they had pulled 3 plugs...nothing. They did admit while trying to start the vehicle they pumped the gas pedal thus they figured it was flooded and pulled the plugs. I don't want to ruin a friendship but would like some ideas as I have had not problems starting this vehicle this winter. There next idea is to have it towed to a service facility...not a good financial move for me.
If someone has an idea, please feel free to contact me at goldporsche944@aol.com.
Thanks in advance...rick
bimmer124 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-06-2010, 08:17 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Can you rent or borrow an OBD2 code reader and pull the diagnostic trouble codes? Then ask your question on the W140 forum and surely someone will be able to help you. Good luck.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1997 s320 won't start kaiming W140 S-Class 11 06-04-2011 03:48 AM
    New 1997 S320 Owner osmanbo General Mercedes-Benz 0 11-29-2008 06:04 AM
    1997 s320 won't start ~~ Update kaiming W140 S-Class 4 07-30-2005 05:26 PM
    1997 s320 transmission kaiming W140 S-Class 0 05-16-2005 04:07 PM
    1997 s320 tomsawyer W140 S-Class 2 02-18-2004 04:58 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome