loses power with acceleration - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-04-2010, 11:08 PM Thread Starter
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
loses power with acceleration

Hi,

When I'm highway driving at approx. 45 mph and then attempt to further accelerate, my E320 loses power to the point where I consider pulling over. As I slow and in fear take my foot off the accelerator, after a minute or so it will accelerate again and behave normally. This has happened twice. Could this be something with the air filter? Any other ideas? thank you
dr.mara2345 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-08-2010, 10:40 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    c180 loses power and stalls help! jackielobster W202 C-Class 2 06-22-2011 08:18 AM
    engine loses power under load 93 BENZ S400SEL W140 S-Class 10 02-21-2010 12:27 PM
    300E loses power when AC its turned on basics4home W124 E,CE,D,TD Class 9 09-19-2008 12:23 AM
    1994 E420 Loses Power timt W124 E,CE,D,TD Class 6 08-21-2007 07:13 PM
    ML 320 loses power and then stops! Steve (Austria) W163 M-Class 10 01-13-2006 02:05 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome