UK GPS Sat Nav location problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-03-2010, 07:28 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
UK GPS Sat Nav location problem

Hi, I am new to this forum but hopefully someone can help me with my problem.

I have a UK 2004 E class and have a problem with the sat nav. The marker on the command unit is showing the location of the car in the wrong place (aprrox 30miles north of where I actually am).

When the car is moving the marker does move but it is moving on the map 30miles away and makes no sense.

Anybody have an idea what the problem could be?

I have been using a 2009 disc which worked fine for 6 months.

Thanks
G
gurda is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-03-2010, 09:55 AM
Outstanding Contributor
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 10,462
Mentioned: 10 Post(s)
Quoted: 356 Post(s)
I'm not going to be much help to you. (but I also have a 2004 MB with a factory fitted COMAND SatNav system in the UK. I am still using the original Nav CD supplied with the car, so it is now a bit out of date with some new roads. (not many, in practice)

Just now and again the display gets totally screwed up, and shows an area miles from where I actually am. Also it sometimes displays the number of satellites in view. Mostly it doesn't. It seems to correct itself.

If the co-ordinates are being incorrectly calculated, it must be an erratic s/w or hardware problem in the COMAND unit. Mine is not frequent enough to bother me, as I do not use the system enough to matter.
keyhole is online now  
post #3 of 4 (permalink) Old 02-03-2010, 10:37 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
If it shows consistently a wrong location and the map seems to move as the car moves, then it must be a bad GPS antenna and the navi processor is working with gyros and speed signal. How many satellites does it report? Probably "0" or "-".

A lot of info on this at the W211 forum.
Diesel Benz is offline  
post #4 of 4 (permalink) Old 11-04-2010, 05:31 AM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have a 2004 E Class and just resolved this problem....
My system was reporting "0" satellites. I purchased a new GPS antenna with blue fakra plug from ebay for $15 and problem fixed.

I mounted the new antenna under the rear parcel shelf.
Slick320 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    COMAND Sat Nav problem - help please Rodge Audio & Telematics Forum 2 05-09-2009 07:02 AM
    GPS misreading on Sat Nav display. pjas1969 Audio & Telematics Forum 6 12-19-2008 08:49 AM
    Newbie Alert!! - Have Sat Nav Problem aabedi General Mercedes-Benz 5 05-26-2008 03:52 PM
    VSS and Reverse wire location for sat nav install. BIG 500SEC W140 S-Class 0 02-02-2008 01:11 PM
    Sat Nav voice problem P18TRG R171 SLK-Class 16 04-14-2006 09:11 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome