I have a problem. Can someone help with an advice? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-20-2010, 07:41 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2009
Vehicle: Mercedes-Benz 190 E year 1980
Location: Albania
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I have a problem. Can someone help with an advice?

I have a Merceds Benz type 190 E produced in december 1989. I am starting to have problems.
When i went in a long trip with that car I put some fuel in it and after that in first kilometers i felt that the car started to loose power. I did 200 km and the problems were increasing. I pushed the gas pedal but the car couldnt take speed and was loosing power more. The speed of car couldnt be more than 60 km/hour. I put the third gear even the forth gear but there was not reaction from the car. It was going in more slow speed. It seemed that it has a problem with injectors. The motor of my car is a motor 2000 cm3 and works with benzine. It has simple carburator with mecanic injectors. Then i stoped to a mechanic and he changed the group of karburator. He changed the place where teh injectors were suported and. The car started to function normally but i noticed that one piston was not working. When the minimo of the car was at the lowest level I had to turn on several times the principal key to start the car. When the minimo was in higher levels I didnt have problems with the principal key to start the car but i am having problems with the economy of the car. It is using too much benzine when i go with the car. Also it seems that the car is working in two pistons. Can anyone tell me what might be the problem of my car? I dont know if i said everything correclty because i am not a good specialist in motorric terms but if somebody what to help me I can tell more particularities later.
Thank you in advance.
Altin
Albin is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Serious suspension problem - Need Advice NoPrayer W201 190-Class 6 07-13-2009 02:08 PM
    Transmission problem ? need your advice MADSLEG W163 M-Class 17 06-25-2008 02:51 AM
    Advice on a problem that they cant seem to fix. Andrew2004az W163 M-Class 3 02-08-2006 06:54 PM
    Need Advice on Windows Problem 91 560SEL W126 S,SE,SEC,SEL,SD,SDL Class 0 05-04-2005 10:18 PM
    BIG PROBLEM...NEED HELP/ADVICE cgmike10 C208/A208 CLK-Class 2 03-03-2003 08:47 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome