Brand new 1988 420 Sel Owner - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-18-2010, 01:11 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Brand new 1988 420 Sel Owner

Hi there everyone.

I am the proud and happy new owner of a nice old 1988 420 SEL I just purchased for $800.00. Unfortunately I do not have a picture. She is a nice Mediterranean Sea-Green color. I first saw that color on this model back in 1992 driving into Paris and thought to myself that one day I would love a car like that. In fact, it was the first Mercedes I had seen that I truly liked the look of despite having always appreciated the solid engineering.

I bought it 4 hours away from me on a day with light snow. This car has never before been driven during winter and now it is back home with me I intend to continue that tradition given I live in a cold area where they salt the roads (furiously!).

The drive back was fine once I replaced the wiper blades and once the front left headlight decided to work again so I didn't have to keep the brights on in order to avoid being pulled over.

Drove smooth and steady and I can feel the underlying 'quality' of the car along with the understated but definite high-end design aspects in the cockpit.

Now I am hoping to get some master tips from enthusiasts here, so now follow a list of initial problems noticed in rough order of what I suspect are the most important ones. In all cases, any suggestions/war stories appreciated. I cannot afford to have zillions of things fixed with every problem and need to zero in ASAP in each case to come up with the right (and hopefully affordable) solution:

1. The oil gauge starts off around 3 and then quickly goes down to 1 or close to 0. The owner whom I called said that always happened but it had plenty of oil. Wrong! It was on empty. After putting in 2 bottles (about half a fill I believe) the gauge behaves in the same way. No apparent leaks. The electrics in general seem a bit iffy so I am wondering if there is something wrong with gauge or if it is telling me there is a serious problem somewhere. Is it normal to fluctuate down to 0 like that even when not empty?

2. There is a leak from the radiator when it's running but I can't yet find out where from. Nowhere obvious. Flowing out the front right lower corner (facing the engine). My guess is that it's a seal or something.

3. The one that bothered me the most driving is that there is NO acceleration when flooring it. Perhaps the pedal is not properly adjusted any more but I doubt it. It is fine in lower geer in that when you push down the engine speeds up. But once in high gear in Drive and you want/need to accelerate, it doesn't shift down and lift off. Ever. So almost no pick up once doing more than about 35 mph. Will be changing fluids and filter for tranny next week but still this is worrisome. I presume that even though this is a big car and a bit of a boat in general that it can indeed accelerate when floored, right? Assuming this is a problem, what are the main things to look for first to correct it?

4. Front left headlight goes off and on. A rear right stop light goes off and on. The driver seat backrest switch goes down-back but not up-forward most times; lowering the driver window sometimes causes the radio to remain on but no longer giving sound. Turning off the radio a very loud popping sound. So in general electrics seem a bit iffy. Is there a simple way to clean everything up, or at least a central area where many wires meet or is it one circuit at a time to check?

5. The window up-down switches in the central console are somewhat depressed, the bottom ones being very hard to push down and it feels like there is no support underneath them at all, i.e. the more you push down the lower they go. Strange. What is supposed to be underneath them or what has happened? Is this going to be easy or very hard to fix.

6. Paint is pretty good, albeit generally faded, and there are a rust spots beginning so this has to be nipped in the bud. Underneath looks fine. However, I am wondering if there is an easy way to take an old paint job like this (it looks like it's the original) and just restore it instantly with some nifty high quality product, or if I decide to repaint after sanding down rust spots and filling etc. if it is best to simply repaint whole thing and if so, is Mercedes official paint available or should I just get the color code and buy decent quality stuff locally?

7. Only have one key - the master key. How hard is it to get a couple of spares and/or get a trunk lock. I do not have the registration card that came with original car with the Key code on it, only the main reg. card with all the other info.

8. Anyone in the Maritime or NorthEast region have suggestions for best way/service/system of rust-proofing? The quality level of this car is so superior that I have no intention of being the one that allows here to fall to pieces even though am in rough environment where corrosion is a continual enemy of any vehicle much over than five years old, let alone 22!

Any helpful tips from those who have experienced similar things with similarly aged Mercedes will be much appreciated!

Last edited by AshleyH; 01-18-2010 at 01:17 PM.
AshleyH is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-20-2010, 12:15 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #3 of 3 (permalink) Old 01-20-2010, 12:40 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, leapyf.

Will try, but there is so much in there about so many different models....

The acceleration issue is fixed. Linkage fine-tuned. Now she drives like an aggressive stallion after a mare in heat. Didn't expect a big, roomy car like this to do that! Neat.

Radio can still turn off when window activated. I suspect there will be little that can be done about things like this without overly major dig-down-deep type explorations; probably best to just live with it.

But was hoping that others had had similar things and could point in right direction. Will check that area at some point but again, so much to go through...
AshleyH is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    new member 1988 420 sel nissan4x4 W126 S,SE,SEC,SEL,SD,SDL Class 2 07-10-2009 06:47 PM
    For Sale 1988 420 sel Hatley535 W126 S,SE,SEC,SEL,SD,SDL Class 2 09-22-2007 09:09 PM
    FS: 1988 420 SEL cmonkee For Sale/Wanted/Trade/Giveaway 1 09-06-2007 07:03 PM
    just purchased..... 1988 420 SEL soup138 W126 S,SE,SEC,SEL,SD,SDL Class 5 06-01-2007 08:22 PM
    1988 420 SEL garage bohemian W126 S,SE,SEC,SEL,SD,SDL Class 1 06-19-2003 01:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome