Vito service indicator reset - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-14-2010, 07:11 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Mercedes 111 cdi vito van (2008)
Location: Devon
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vito service indicator reset

Hi, my vehicle needs your help!, it's a 2008 111 cdi Vito van, and i need help to reset the service indicator?, thanks.
dannydevito is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-14-2010, 09:55 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
post #3 of 8 (permalink) Old 01-15-2010, 02:38 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Mercedes 111 cdi vito van (2008)
Location: Devon
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks guys but these links are all car related!, it's a van i need help with !
dannydevito is offline  
 
post #4 of 8 (permalink) Old 01-19-2012, 01:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Mercedes 111 cdi vito van (2008)
Location: Devon
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
'08 Vito 639 model assyst reset problem

well here I am 2 years on still trying to find out how to reset the service indicator.I gave up last time & took it to a dealer but now it's out of warranty so it's gotta be serviced elsewhere HELP!!!
dannydevito is offline  
post #5 of 8 (permalink) Old 01-19-2012, 04:44 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,614
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Vito can be an difficult one to reset without using SDS but here are the instructions. Ensure all doors and hood are closed before trying this;
Attached Thumbnails
Click image for larger version

Name:	Snap3.jpg
Views:	450
Size:	31.2 KB
ID:	421333   Click image for larger version

Name:	Snap4.jpg
Views:	478
Size:	34.2 KB
ID:	421334   Click image for larger version

Name:	Snap5.jpg
Views:	437
Size:	28.2 KB
ID:	421335   Click image for larger version

Name:	Snap6.jpg
Views:	279
Size:	10.3 KB
ID:	421336   Click image for larger version

Name:	Snap7.jpg
Views:	1193
Size:	37.2 KB
ID:	421337  

Attached Images
 

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #6 of 8 (permalink) Old 01-20-2012, 03:46 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Mercedes 111 cdi vito van (2008)
Location: Devon
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, that works, sort of!, I'm now able to access the reset menu, which I've done but I can't clear the reminder that shows 27days( counting down) & 2 spanners!, help more please!!
dannydevito is offline  
post #7 of 8 (permalink) Old 01-20-2012, 04:19 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,614
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Quote:
Originally Posted by dannydevito View Post
Thanks, that works, sort of!, I'm now able to access the reset menu, which I've done but I can't clear the reminder that shows 27days( counting down) & 2 spanners!, help more please!!
Step 1 is the important step and if it does not work with only ignition on then start the engine and see if total km appears, it does take some time. Maybe as much as 10 minutes.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #8 of 8 (permalink) Old 03-02-2012, 02:42 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Mercedes 111 cdi vito van (2008)
Location: Devon
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for all of that, however my Vito 111 cdi (639 series), had to be connected to a service module to be reset, I managed the oil change reset but the spanner/ two spanner logo wouldn't reset until it was plugged in!, some would say that was progress!, ( not me ), that's it for another 2 years anway!
dannydevito is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Service indicator reset markbaumel@yahoo.com W211 E-Class 21 02-25-2016 12:18 AM
Reset service indicator mikefili W204 C-Class 12 07-27-2014 12:30 PM
How do you reset the Service indicator? gbmotorsport C219 CLS-Class 21 07-26-2012 05:42 PM
reset my Service indicator Vince_E500 Audio & Telematics Forum 7 03-08-2007 04:30 PM
how to reset the service indicator vinceching W140 S-Class 2 04-20-2004 11:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome