92 300 S 3.2 speedometer problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-11-2010, 07:48 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2010
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
92 300 S 3.2 speedometer problems

I have a 92 300 S class that the speedometer does not work. I am trying to find out where the sensor is located. Some are saying it is the left front ABS sensor and others are saying it is the the ABS sensor in the rear end. Does anyone have a definite answer as to were the sensor is located.
jtchri is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-11-2010, 10:14 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,785
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
The sensor should be mounted on the transmission. Fact is that in electronic era those things are harder to find.
Use Russian site for picture of the system.
Welcome to the forum.
Kajtek1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    SPEEDOMETER PROBLEMS metalhead W123 E,CE,D,CD,TD,TE Class 11 07-17-2009 07:24 AM
    82 300 SD Speedometer stopped working drain69 W126 S,SE,SEC,SEL,SD,SDL Class 2 01-04-2005 09:14 AM
    300 E speedometer Six_wheeler W124 E,CE,D,TD Class 6 12-17-2004 05:28 PM
    speedometer problems reliablebruce General Mercedes-Benz 0 05-08-2004 02:32 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome