Fuel injection problem for Benz 300E - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-07-2010, 04:20 PM Thread Starter
BenzWorld Newbie
 
jtwhr's Avatar
 
Date registered: Jan 2010
Vehicle: Mercedes Benz 300E
Location: Kelowna, BC Canada
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jtwhr
(Thread Starter)
Fuel injection problem for Benz 300E

Hi--I'm new to the site, this is a similar site to celicasupra. I just bought an '88 Mercedes Benz 300E. It has 215,000 km on it. I have always wanted to be an owner of a Mercedes Benz, so when I seen this, I could not pass it up. I am having a couple of issues with it right now. Being that it is mechanical fuel injection, it was running--I added gas to it, and it just died. I cannot get it started. I have a power drain to my battery, but first things first--with this mechanical fuel injection, do I bleed the fuel system if there is an airlock? Has anyone had similar problems with these inline 6 in the 300E? The wiring issue should not be hard to figure out, but I am kind of stumped on why it just stalled. I have not had to much experience with these mechanic fuel injections--any kind of info or any kind of direction that someone could point me too would be very appreciated. What is the size of our wheels in mm.
jtwhr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-07-2010, 06:16 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,785
Mentioned: 9 Post(s)
Quoted: 1127 Post(s)
welcome to the forum. It's been long time since I own car with mechanical FI, but I still remember how sensitive the system was to bad fuel.
Your problem started after fill up, what raise the red flag.
Go to proper model section for experience from the same model owners.
Kajtek1 is offline  
post #3 of 4 (permalink) Old 01-12-2010, 12:48 AM
BenzWorld Veteran
 
Date registered: Apr 2009
Vehicle: Current: 1987 560 SEC US, former factory trained MB tech 10 years, owner of 14 others.
Location: Spokane, WA.
Posts: 723
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It is CIS, not mechanical. It is self-bleeding. Check to see if your fuel pump is on when you try to start it. It is possible there is a relationsip between your voltage drain and your lack of starting. Check all your fuses first of all.
renaissance_warrior is offline  
post #4 of 4 (permalink) Old 01-12-2010, 03:53 AM
BenzWorld Member
 
Benz in Brazil's Avatar
 
Date registered: Jul 2008
Vehicle: 1976 W116 - 280S / 1994 W140 - S320
Location: Jundiai - Brazil
Posts: 82
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
My 300E doesn't start if the battery is low on charge. I left the car in a bodyshop to have some scratches painted over and they couldn't get the car to start after being stationary two weeks. Once the battery was on full charge, she started up no problem. I believe the fuel injection system is actually electro-mechanical so it may have something to do with it but, do look at the fuses (remove and clean) and relays too.

Last edited by Benz in Brazil; 01-12-2010 at 03:59 AM.
Benz in Brazil is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    124 230TE fuel injection problem drchatha W124 E,CE,D,TD Class 0 12-23-2008 05:26 AM
    Fuel injection problem? Benzzy280 W123 E,CE,D,CD,TD,TE Class 4 02-23-2008 06:45 AM
    Fuel injection problem? Benzzy280 W123 E,CE,D,CD,TD,TE Class 0 02-12-2008 07:04 PM
    1984 SD 380 Fuel Injection Problem richard_john_81 General Mercedes-Benz 1 06-23-2006 11:36 AM
    1977 300D Fuel Injection Problem trickdog W123 E,CE,D,CD,TD,TE Class 3 03-23-2006 11:18 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome