Codes PO173, 170 - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-05-2010, 10:08 AM   #1 (permalink)
T4B
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: 2001 E320 All Black
Posts: 7
Post Codes PO173, 170

My 2001 E320 was posting codes PO 170, 171, 173.
I cleaned my original MAF, with CRC cleaner, to no avail. I replaced the MAF with an autozone purchased MAF for $200. I now am getting codes of just PO 170, 173. Did I make a mistake of getting an autozone MAF, do I need to spend $529 at the dealership to get a mercedes MAF with a new time release virus?
I'd hate to start throwin 300+ at each O2 sensor.

Anyone who can help please do!!

Thanks,

Steve
T4B is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-05-2010, 11:04 AM   #2 (permalink)
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 101,000+
Location: West Virginia, USA
Posts: 17,191
Lifetime Premium Member
I don't know what your problem might be but you can buy a genuine Bosch MAF from online retailers for less than $529 (avoid eBay). Bosch says O2 sensors have a lifetime of 100,000 miles. Are yours anywhere near that old?

Come join us on the W210 forum, there are quite a few experts willing to lend a hand. Welcome to the forum.
__________________
Mercedes Benz - Das beste oder nichts!
Musikmann is offline   Reply With Quote
Old 01-05-2010, 11:24 AM   #3 (permalink)
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 27,458
Steve, I can't add more to what MM said, except to tell you that the general forum can be kind of a wasteland at least as to specific things about specific models. The W210 forum is chock full of information about your car, so that's the place to head.

And BTW, the only thing I buy at Autozone for my 2001 E320 is oil, windshield washing fluid and car wash products. Genuine Bosch MAF at autohausaz.com is the way to go, about $175 with free shipping last time I checked.

Last, please click user cp and add your vehicle and location information to your profile as that is often useful.

See you in the 210 section.
__________________
Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline   Reply With Quote
Old 01-05-2010, 11:24 AM   #4 (permalink)
T4B
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: 2001 E320 All Black
Posts: 7
Quote:
Originally Posted by T4B View Post
My 2001 E320 was posting codes PO 170, 171, 173.
I cleaned my original MAF, with CRC cleaner, to no avail. I replaced the MAF with an autozone purchased MAF for $200. I now am getting codes of just PO 170, 173. Did I make a mistake of getting an autozone MAF, do I need to spend $529 at the dealership to get a mercedes MAF with a new time release virus?
I'd hate to start throwin 300+ at each O2 sensor.

Anyone who can help please do!!

Thanks,

Steve
The car currently has 79,000 on it, but this problem prolly started back about around 60k.
I keep clearing the CEL, but it always comes back on within 20 miles,
and I can't stand seeing it anymore.
I've already replaced the whole exhaust system once, and Im afraid if I keep
driving with this problem, I'll have to do it again.

The MAF I bought at autozone came in a Bosch Box, So I assume it is a genuine
Bosch Product.

Steve
T4B is offline   Reply With Quote
Old 01-05-2010, 11:26 AM   #5 (permalink)
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 27,458
Quote:
Originally Posted by T4B View Post
The car currently has 79,000 on it, but this problem prolly started back about around 60k.
I keep clearing the CEL, but it always comes back on within 20 miles,
and I can't stand seeing it anymore.
I've already replaced the whole exhaust system once, and Im afraid if I keep
driving with this problem, I'll have to do it again.

Steve
That pretty much confirms it's the MAF, since when it fails it cooks the cats if it's ignored long enough. Get that Cardone unit out of there and replace with bosch, check the intake tube to make sure it's all connected properly as well when you change it.

Fix the problem, don't just clear the codes. If you're going to DIY, spend time in the 210 forum so you do it right, otherwise drop off the car and your bank account at the dealer.
Check Codes is offline   Reply With Quote
Old 02-16-2010, 05:12 AM   #6 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2010
Vehicle: Snow White 2001 E320
Location: Orlando, FL
Posts: 11
Codes PO170 & 173

Hi Steve,

I'm new to this forum and just bought my wife an '01 E320 6 days ago. The CEL was on and I had the same codes. After joining this forum and searching I also found the threads on cleaning the MAF sensor. So far so good after a good clean. I also cleaned the OEM air filter as well. I want to change out the OEM air filter to a K&N just to get better air flow.

I guess I got lucky on just cleaning it. Maybe you have a bigger issue but I'll stay tuned to follow this thread in case my CEL comes back on. Sorry I couldn't be of more help but the simple clean has solved my problem so far.

The car we bought has only 55K miles and is in MINT condition. It has only been driven 4000 miles in the last 2 years.

Thanks to everyone for the info,
Shawn
srmack is offline   Reply With Quote
Old 02-16-2010, 08:38 AM   #7 (permalink)
BenzWorld Elite
 
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Quote:
Originally Posted by srmack View Post
I also cleaned the OEM air filter as well. I want to change out the OEM air filter to a K&N just to get better air flow.
You won't.

But the oil mist will ruin your MAF.

It's a Mercedes--there's nothing wrong with the OE intake system.
__________________
Kent Christensen
Albuquerque
'07 GL320CDI
lkchris is offline   Reply With Quote
Old 02-16-2010, 02:42 PM   #8 (permalink)
BenzWorld Member
 
Todd157k's Avatar
 
Date registered: Jan 2010
Vehicle: 1999 SLK230 M5
Location: Simi Valley, CA
Posts: 65
There are several things to cause a lean code. Start with the simple ones which is the intake AFTER the maf. Make sure the system is secure and no cuts/splits in the intake ducting. Secondly, you said you replaced the exhaust system.. are you sure the O2 sensor wires are clear of the exhaust piping/manifolds?
Usually problems like this are nothing more than a torn/split intake tube.
__________________
2006 SLK55
2006 CLS500
1999 Mercedes SLK230 Manual
2004 Z06 525rwhp/460rwtq
2005 Dodge Ram Daytona 4x4
Todd157k is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Error codes PO170 & PO173 - ? Dadaman General Mercedes-Benz 8 04-22-2011 01:27 PM
codes PO173, PO170 & PO446 kwiklee W163 M-Class 2 08-13-2007 07:08 PM
'99 C280 with Check Engine Light - Codes PO170 & PO173 1957Birdman W202 C-Class 8 04-20-2007 09:25 AM
Pollen Season = CEL = PO170 & PO173 Codes CCORLEY W163 M-Class 1 05-16-2005 09:59 AM
Pollen Season = CEL = PO170 & PO173 Codes CCORLEY W163 M-Class 1 05-15-2005 06:46 AM


All times are GMT -7. The time now is 12:06 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.