Engine dies while driving. Help! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-04-2010, 11:48 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2010
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine dies while driving. Help!

I have a problem which i hope you won't mind reading. I drive an MB 230E 124-body 1989 model manual transmission sedan. The problem is that it dies while i'm driving and i noticed the ABS dashboard lamp turns on. At first i thought it had to do with the ignition coil (w/c i replaced) but no. Now it dies only after 4-5 minutes of idling and the ABS lamp comes on. I can't drive it anymore bec. it'll die on the road for sure. Some say it's the fuel filter or the fuel pump relay, or the fuel pump itself, or the over voltage protection relay, or perhaps the distributor cap, or the battery itself. i'm confused now. Any assistance is appreciated. Thank you.
RGN07 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-05-2010, 09:34 AM
BenzWorld Elite
Date registered: Dec 2008
Vehicle: w204 (C350ELE)
Location: Miami, Fl and Mar del Plata, Argentina
Posts: 1,262
Mentioned: 0 Post(s)
Quoted: 1 Post(s)

You are facing a situation that requires patience to follow the electrical crumbs so a correct diagnosis can be made. Take it to a good MB indie, you'll save money in the long run.

A car would show appreciation for preventive maintenance by never leaving his owner stranded.

Defensive Driving is never having to say you're sorry: a true love story between man and machine.
JoeVal is offline  
post #3 of 3 (permalink) Old 01-05-2010, 10:13 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,532
Mentioned: 9 Post(s)
Quoted: 1070 Post(s)
Common issue is that ABS light come on at low voltage, so my first guess would be that you have a problem with charging system where low voltage is killing ignition or fuel pump.
Shouldn't be too hard to hook up voltmeter? Even the plug-in one with LED lights on it.
Kajtek1 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    190E 2.6: While running/driving, engine "stalls", tach dies, BUT..... lars-tetens W201 190-Class 18 07-30-2009 07:19 PM
    Engine trembles and dies while driving. FUEL PUMP?? BenzWithers W124 E,CE,D,TD Class 7 03-31-2009 11:12 PM
    HELP!! 91 260E engine dies after driving just a few miles. Cold start OK. danieldjx W124 E,CE,D,TD Class 0 02-27-2008 05:15 AM
    HELP!! 91 260E engine dies after driving just a few miles. Cold start OK. danieldjx W124 E,CE,D,TD Class 0 02-27-2008 04:59 AM
    Engine dies when driving fast or up-hill privremena_adresa General Mercedes-Benz 20 11-01-2006 07:01 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome