2002 C320 in limp mode after a jump start - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-03-2010, 02:10 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 83 300SD ,87 300 D Turbo, 95 E 300 D, 96 E300 D, 98 E300TD, 00 C230 Compressor, 02 C 320 Wagon,
Location: Downey, CA
Posts: 121
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
(Thread Starter)
2002 C320 in limp mode after a jump start

My car is in limp mode after a jump start, anyone could tell me how to reset it? or has to be dealer-only-repair.
Thanks for your fed back.
mymini1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-04-2010, 12:37 PM
Supporting Vendor
 
FCP Euro's Avatar
 
Date registered: Jul 2008
Posts: 697
Mentioned: 0 Post(s)
Quoted: 22 Post(s)
Disconnect the battery for about 10 minutes and then reconnect it. The car should be ok now. I had this problem after a jump start myself.


Quality & Service, Guaranteed for Life
FCP Euro - OEM & Genuine European Auto Parts Online
FCP Euro is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    limp home mode, later failure to start - Fixed andrewdough W203 C-Class 1 08-17-2009 12:06 PM
    Need help with limp mode eric242340 Off-Topic 20 07-18-2009 03:11 AM
    Limp Home Mode Symptoms 2002 C240 alexsystems General Mercedes-Benz 0 02-18-2009 11:59 PM
    Limp Mode noelchambers R170 SLK-Class 4 08-18-2008 02:27 PM
    2002 C320 "Economy Mode" button stuck - no air Thcuse W203 C-Class 1 06-19-2008 03:28 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome