my car shakes when i start it up - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-02-2010, 05:49 AM Thread Starter
BenzWorld Junior Member
 
CLK KID's Avatar
 
Date registered: Dec 2009
Vehicle: 1999 clk320
Location: NEW YORK
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to CLK KID
(Thread Starter)
Angry my car shakes when i start it up

on rare occasion my 1999 clk 320 will shake upon start and i see the rpm shaking also, and sometimes when im driving it will do it and when i give it gas the car wants to move but stutters like its going to stall, ill have it floored then it will just be doing 5 mph then i will have to ease off the gas and wait for it to stop, its very rare when it does this and happens only for a few seconds, some one said it could be the spark plugs im going to look into that, i hope its nothing serious.

1999 Mercedes Benz clk 320- with 19's

2005 Polaris predator 500 (troy lee edition)-full white brothers exhaust
Ruff Ryders!
CLK KID is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-02-2010, 12:44 PM
BenzWorld Veteran
 
Date registered: Apr 2009
Vehicle: Current: 1987 560 SEC US, former factory trained MB tech 10 years, owner of 14 others.
Location: Spokane, WA.
Posts: 723
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I would run a can of 44k in the fuel. It sounds like somethin is stickin in the air delivery system in the cold-start circuit. Probably just fuel varnish.
renaissance_warrior is offline  
post #3 of 9 (permalink) Old 01-03-2010, 05:40 AM Thread Starter
BenzWorld Junior Member
 
CLK KID's Avatar
 
Date registered: Dec 2009
Vehicle: 1999 clk320
Location: NEW YORK
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to CLK KID
(Thread Starter)
Lightbulb

my check engine light came on and it said i need an oxygen sensor could that be the problem?? it happens wen i start it if its really cold out and randomly when im driving

1999 Mercedes Benz clk 320- with 19's

2005 Polaris predator 500 (troy lee edition)-full white brothers exhaust
Ruff Ryders!
CLK KID is offline  
post #4 of 9 (permalink) Old 01-04-2010, 01:19 PM
BenzWorld Elite
 
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
If it shakes it means it isn't running on all six cylinders.

Kent Christensen
Albuquerque
'07 GL320CDI
lkchris is offline  
post #5 of 9 (permalink) Old 01-04-2010, 01:25 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
An out of range O2 sensor will cause a CEL. Average lifetime on those is 100,000 miles. Did your car tell you that or did you have it scanned for error codes?

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #6 of 9 (permalink) Old 01-04-2010, 02:53 PM
BenzWorld Member
 
Date registered: Nov 2009
Vehicle: 2001 S55 AMG
Location: Westchester New York
Posts: 68
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Could be bad spark plugs, also motor mounts can make the car shake if they are weak.

But if you codes tell you O2 sensors, take a look at that first and narrow it down from there.
crashtest is offline  
post #7 of 9 (permalink) Old 01-04-2010, 04:44 PM
BenzWorld Elite
 
Date registered: Dec 2008
Vehicle: w204 (C350ELE)
Location: Miami, Fl and Mar del Plata, Argentina
Posts: 1,262
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Post

Is your catalytic converter in your exhaust? Otherwise, it got finally clogged.

Also, clean your fuel intake. It must have obstructions to a free fuel mix flow.

Cheers,


A car would show appreciation for preventive maintenance by never leaving his owner stranded.

Defensive Driving is never having to say you're sorry: a true love story between man and machine.
JoeVal is offline  
post #8 of 9 (permalink) Old 01-05-2010, 08:03 PM Thread Starter
BenzWorld Junior Member
 
CLK KID's Avatar
 
Date registered: Dec 2009
Vehicle: 1999 clk320
Location: NEW YORK
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to CLK KID
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
An out of range O2 sensor will cause a CEL. Average lifetime on those is 100,000 miles. Did your car tell you that or did you have it scanned for error codes?
yea my check engine light came on and said an o2 sensor needed to be replaced and whats a CEL?

p.s. my car has 172,000 miles on it!

and thank you all for the help its helped me alot thanks to all

1999 Mercedes Benz clk 320- with 19's

2005 Polaris predator 500 (troy lee edition)-full white brothers exhaust
Ruff Ryders!
CLK KID is offline  
post #9 of 9 (permalink) Old 01-05-2010, 09:22 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by CLK KID View Post
yea my check engine light came on and said an o2 sensor needed to be replaced and whats a CEL? p.s. my car has 172,000 miles on it! and thank you all for the help its helped me alot thanks to all
Sorry CEL means check engine light. Your O2 sensors are way past due if not replaced before now.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Car shakes bloodpirate W124 E,CE,D,TD Class 5 01-20-2010 06:31 AM
    car shakes at idle psharpster W203 C-Class 21 04-06-2008 04:45 PM
    Another problem, My car shakes... richt420 W220 S-Class 3 01-14-2008 09:35 PM
    car shakes while stopping in D bulahee W201 190-Class 7 12-22-2005 12:20 PM
    my car shakes when i turn it off... krk230 R170 SLK-Class 9 08-18-2004 09:15 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome