PSE help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-30-2009, 02:14 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
PSE help

I have a 1996 S420 and the central locking system, headrests and trunk lock did work, so I bought a vacuum pump off of ebay. The problem is that my car didn't have a vacuum pump in it at all so I don't know where the vacuum pump tubes go. I figured out the wiring part of it (I think), because the connector piece was taken off, but I have no clue as to how to connect the vacuum tubes to the pump. Any help would be appreciated. Thank you.
TSmith333 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-31-2009, 04:47 AM
BenzWorld Elite
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T current 2014 lexus LS460
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Maybe this will help
Attached Files
File Type: pdf retro pump.pdf (46.1 KB, 71 views)
Peter Guenther is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    What are the other plugs on the PSE for? bazookatooth W140 S-Class 0 05-22-2009 11:20 AM
    PSE pump M_1313 R170 SLK-Class 0 08-18-2008 08:28 PM
    pse cleaned and rebuilt... but looks like time for a new pse? sightless R170 SLK-Class 2 05-16-2008 05:59 PM
    PSE is out. prtdvl R170 SLK-Class 6 08-04-2007 10:04 PM
    TimePort PSE Replacement for StarTac PSE in MikBox Installation Skylaw Audio & Telematics Forum 15 03-31-2005 04:48 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome