New W123 owner, north royalton, OH sayin hi - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-27-2009, 02:55 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2009
Vehicle: 1984 Mercedes-Benz 300D Turbo Diesel
Location: North Royalton, OH
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New W123 owner, north royalton, OH sayin hi

just bought a 1984 300D Turbo Diesel 5cyl w123 3 days ago from craigslist for 525 bucks and stumbled across this forum, figured id better sign up with all the little issues this car has

switches only working half the time,

the heater blows hot then switches to cold and back and forth for no apparent reason,

the brake booster is shot,

i see diesel pooling around each of the fuel injector looking things on the drivers side of the motor below the manifold (injectors???),
says its a turbo diesel but ive yet to hear the turbo, not sure if i even should
im not familiar with this car whatsoever and ive never even owned a diesel or even anything other than american cars.

it seems quite slow, i took a video of a WOT run from 0-60mph....... from when i stomp it, til the time it hits 60mph it takes around 20 seconds.

the trunk lid u have to slam it just right with your hand directly centered over the mercedes emblem or it will pop open as u drive, same with the hood cept it doesnt open all the way as its stopped by the 2nd latch that he made out of the zip ties except you have to push it closed with your hand on the drivers side just immediately past the hood ornament.

the door handles stick on the back door to the point where you have to push the handle back in or the door just flys open when your driving

the dome light didnt work for 3 days but out of nowhere it worked today for about an hour

if you touch the hazard light switch your turn signals fail and you have to wiggle the hazard switch to get them to come back on

when you turn it off about 20% of the time it will continue to run for about 10-15 seconds but the other 80% of the time its instant as soon as you turn off the key.

the sunroof opens, but doesnt close, i was warned by previous owner him and his "250 lb buddy" both had to push it shut and it took them close to an hour to do so.

the "backlighting" if you could even call it that for the speedometer which is that little directed bulb only worked on the drivers side for past couple days until today it worked for about 10 minutes as i was driving down the road.

out of nowhere the battery went dead from when i parked it, went inside to work, spent 10 minutes inside doing dishes and grabbed my next delivery. but i got a jump start, and now the battery seems fully charged (i think the battery cables maybe shot??)

the passenger front door lock button was unscrewed and the metal pin fell down inside the door and up against something meaning i cant lock the passenger door. which is fine since the drivers side keylock seems to be frozen so i couldnt lock it up anyways

he broke something in the hood latch and now to open the hood you have to pull this "handle" made of 2 zip ties to open it

i have about 4" of play right to left in the steering wheel, not sure how related it is but if i go on the highway over 60-65mph it starts to shake like im going over small bumps or pebbles in the road but right at 60 or below or turning the steering wheel in the slop to the right it stops and smoothens out.

with the cruise control running if i turn on the heat it shuts off the cruise control.

seems to constantly smoke from under the hood not really noticable except at night with the headlights on idling in peoples driveways, yea it smokes around the injectors as i mentioned earlier but it also seems to smoke from somewhere lower on the motor on the drivers side near the middle when looking at it from the drivers side fender.

yeah this is a huge list of problems, but im a car guy who loves to tinker with things i know absolutely nothing about. i plan on trying to get everything figured out and fixed by myself or with the (cheap) help of friends. im not saying i want to restore it to showroom quality, i just want to get everything thats broken on it fixed or rigged enough for this car to last me some good years into the future. there is nothing yet thats affecting the drivability with the small exception of the brake booster but before anyone gets too scared there is SOME vacuum going to it and ive figured it out that it stops fine as long as i dont ride the brakes too much as im stoping and waste the small amount of vacuum it has built up so im continuing to drive it. she has 257,000 miles on her and from what im reading thats barely broken in, im not made of money as i dont know if you could guess by my earlier statement, i deliver pizza for a living and i will be using this car for it since i needed a reliable solid vehicle able to withstand many many miles of stop and go traffic. a little about myself, im 26yrs old, married, have a 7yr old daughter, 4 cats (wifeys pets, just cant say no to her). heres a pic of my car and the 0-60mph video i spoke of before, which is WIDE OPEN THROTTLE from a dead stop. i hope to have good relations with this forum in the future and hope that i can start crossing items off my list little by little with the help of this forum.



Imageshack - vid00028 - Uploaded by mikeroark

Last edited by mikeroark819; 12-27-2009 at 03:02 AM. Reason: added more problems
mikeroark819 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-27-2009, 09:46 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,676
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #3 of 4 (permalink) Old 12-27-2009, 10:03 AM
BenzWorld Elite
 
F1Bobby's Avatar
 
Date registered: Sep 2008
Vehicle: C55 AMG
Location: People's Republic of California
Posts: 2,174
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome!
F1Bobby is offline  
post #4 of 4 (permalink) Old 12-29-2009, 12:47 PM
BenzWorld Elite
 
Rmac58's Avatar
 
Date registered: Nov 2007
Vehicle: 2013 MINI Copper S Clubman, '84 300CD-weekend car
Location: central Va
Posts: 10,152
Mentioned: 0 Post(s)
Quoted: 139 Post(s)
Quote:
Originally Posted by mikeroark819 View Post
just bought a 1984 300D Turbo Diesel 5cyl w123 3 days ago from craigslist for 525 bucks and stumbled across this forum, figured id better sign up with all the little issues this car has

switches only working half the time, which ones?

the heater blows hot then switches to cold and back and forth for no apparent reason, may be a failing CCU.

the brake booster is shot, other thread, it should hold vacuum, using various reducing lines, hook up a mity-vac to the booster itself, pump away, this will take a while, does it hold vacuum?

i see diesel pooling around each of the fuel injector looking things on the drivers side of the motor below the manifold (injectors???),
says its a turbo diesel but ive yet to hear the turbo, not sure if i even should
im not familiar with this car whatsoever and ive never even owned a diesel or even anything other than american cars. more than likely the jumper fuel lines need replacing, just pull 'em off, probably old and dried, be careful to NOT nick the metal nipples if you have to cut them off. Push on new lines, get the right stuff, 3.2mm braided line.

it seems quite slow, i took a video of a WOT run from 0-60mph....... from when i stomp it, til the time it hits 60mph it takes around 20 seconds. Remove the aircleaner housing and "U"m tube, see if the turbo spins by hand.

the trunk lid u have to slam it just right with your hand directly centered over the mercedes emblem or it will pop open as u drive, same with the hood cept it doesnt open all the way as its stopped by the 2nd latch that he made out of the zip ties except you have to push it closed with your hand on the drivers side just immediately past the hood ornament. Was it in an accident? There is an adjustment for the trunk, sounds like a rigged up job on the hood, post pics if you can.

the door handles stick on the back door to the point where you have to push the handle back in or the door just flys open when your driving spray some lube, work it around.

the dome light didnt work for 3 days but out of nowhere it worked today for about an hour switching points mat be dirty.

if you touch the hazard light switch your turn signals fail and you have to wiggle the hazard switch to get them to come back on could be a flasher issue, a silver square box behind the button.

when you turn it off about 20% of the time it will continue to run for about 10-15 seconds but the other 80% of the time its instant as soon as you turn off the key. classic vacuum leak, try plugging off the doors.

the sunroof opens, but doesnt close, i was warned by previous owner him and his "250 lb buddy" both had to push it shut and it took them close to an hour to do so. probably a dirty tube that houses the cable, you're going to have to clean it out.

the "backlighting" if you could even call it that for the speedometer which is that little directed bulb only worked on the drivers side for past couple days until today it worked for about 10 minutes as i was driving down the road. these lights are very low even at their brightest, sounds like one is burnt out, they work off a dimmer (rheostat) knob, same one as the trip odo, but spin it for the lights, common failure item.

out of nowhere the battery went dead from when i parked it, went inside to work, spent 10 minutes inside doing dishes and grabbed my next delivery. but i got a jump start, and now the battery seems fully charged (i think the battery cables maybe shot??) maybe, inspect all the connections.

the passenger front door lock button was unscrewed and the metal pin fell down inside the door and up against something meaning i cant lock the passenger door. which is fine since the drivers side keylock seems to be frozen so i couldnt lock it up anyways you'll have to pull the panel to retrieve that piece, can you lock it from outside with the key? The drivers lock may have an air lock condition.

he broke something in the hood latch and now to open the hood you have to pull this "handle" made of 2 zip ties to open it again, pics.

i have about 4" of play right to left in the steering wheel, not sure how related it is but if i go on the highway over 60-65mph it starts to shake like im going over small bumps or pebbles in the road but right at 60 or below or turning the steering wheel in the slop to the right it stops and smoothens out. potentially dangerous, inspect the front steering system carefully.

with the cruise control running if i turn on the heat it shuts off the cruise control. most cruise control units don't work at all, not vacuum related.

seems to constantly smoke from under the hood not really noticable except at night with the headlights on idling in peoples driveways, yea it smokes around the injectors as i mentioned earlier but it also seems to smoke from somewhere lower on the motor on the drivers side near the middle when looking at it from the drivers side fender. may be drifting from the passenger side, as that's where the exhaust manifold is, I bet you have a failed flex pipe just below/behind the turbo.

yeah this is a huge list of problems, but im a car guy who loves to tinker with things i know absolutely nothing about. i plan on trying to get everything figured out and fixed by myself or with the (cheap) help of friends. im not saying i want to restore it to showroom quality, i just want to get everything thats broken on it fixed or rigged enough for this car to last me some good years into the future. there is nothing yet thats affecting the drivability with the small exception of the brake booster but before anyone gets too scared there is SOME vacuum going to it and ive figured it out that it stops fine as long as i dont ride the brakes too much as im stoping and waste the small amount of vacuum it has built up so im continuing to drive it. she has 257,000 miles on her and from what im reading thats barely broken in, im not made of money as i dont know if you could guess by my earlier statement, i deliver pizza for a living and i will be using this car for it since i needed a reliable solid vehicle able to withstand many many miles of stop and go traffic. a little about myself, im 26yrs old, married, have a 7yr old daughter, 4 cats (wifeys pets, just cant say no to her). heres a pic of my car and the 0-60mph video i spoke of before, which is WIDE OPEN THROTTLE from a dead stop. i hope to have good relations with this forum in the future and hope that i can start crossing items off my list little by little with the help of this forum.



Imageshack - vid00028 - Uploaded by mikeroark
The turbo not spooling up, or the waste gate not closing can be a number of items.
You may want to tackle one item at a time with a thread on each.
Good luck and keep us posted.

'13 MINI Cooper Clubman S-daily driver
'84 CD-weekender!
Rmac58 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    W123 and W126 is sayin' hello from Budapest, Hungary kicsmocs General Mercedes-Benz 1 10-12-2009 11:56 AM
    Hello there from another W123 Owner HowardDonovan General Mercedes-Benz 1 10-11-2009 01:50 PM
    I'm Just Sayin' Don't stand under the Tree mcbear Off-Topic 5 08-20-2008 07:01 PM
    WTB Front Seats for W123 Palomino North TX cchkaiban For Sale/Wanted/Trade/Giveaway 0 10-01-2007 12:25 PM
    First Formal W123-Exclusive Car Show in North America? vlayton W123 E,CE,D,CD,TD,TE Class 8 09-10-2006 10:43 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome