W210 Alarm Woes - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-26-2009, 04:35 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
W210 Alarm Woes


Crikey... Only registered ten minutes ago and we're already asking about how to fix the flaming thing!

We're cursed with a W210. One of the original ones that go rusty as part of the original sales package and every week is a new problem.

This weeks problem is not stopping us from using the car but it is a pain the backside.

We had the batteries in the key-fob go dead a few days ago which was an exciting freezing our nuts off in the snow while we waited for the AA to come and sort it out for us.

Since then, we can lock the car, but the alarm will wait 20 seconds for you to get to a suitable embarrassing distance from the car before going off... VERY loudly!

We've silenced the alarm by turning the key under the bonnet, but the indicators still blink and it behaves n a silly senile manner and is generally winding us up.

We've done a little bit of looking around and seen two things that seem to sound liek possibilities, but self-diagnosis is a dangerous past-time so we wanted to ask people more knowledgeable in such matters.

So far, we're wondering if it's a key synch issue (although we can lock & unlock the car and drive it without any problems) or if it a PSE Pump thing (that I don;t understand what it is exactly and according to what we've read on the internet thus far involves dis-assembling the entire car to get to it.)

We are decidedly pikey and have no money so we're loathe to take it to a Benz dealer/servicer to have it looked at. But if there is a 'relatively' easy fix then we'd very much like to hear your thoughts on this.


stargazerforest is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-26-2009, 08:26 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
The PSE (pneumatic system pump) in a W210 is handy and under the rear seat. I don't know if that's the problem but you might at least take a look at it. When water gets around it there are various things that can happen. It also operates the door, trunk and fuel filler door so if those still work?

Try copy and pasting your post om the W210 thread and you might get an answer there. Look in the sedans section and good luck.

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 12-27-2009 at 07:34 AM.
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    alarm goes off when doors opened w210 cheapsk8 W210 E-Class 4 09-18-2009 06:34 AM
    Alarm goes off when doors opened w210 cheapsk8 W210 E50 AMG, E55 AMG 1 09-17-2009 12:21 PM
    wtb: w210 parktronic & towing alarm retrofit youngblood For Sale/Wanted/Trade/Giveaway 0 02-09-2009 07:55 PM
    swapped trunk actuator, now alarm/locking woes ducatipaso W201 190-Class 3 05-04-2008 10:21 PM
    W210 - E420 transmission woes... E420White W210 E-Class 6 03-01-2007 09:52 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome