1989 190e ABS Problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-08-2009, 06:02 PM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2009
Vehicle: 1989 190e 2.6
Location: Las Vegas
Posts: 20
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1989 190e ABS Problem

Hi everyone,

I have a 1989 190e Mercedes Benz, Recently I been having problems with My ABS (Anti Lock Braking system), the light turns on after 3 min. and it lowers my RPM and if I dont keep pumping the gas it eventually dies...if I turn off my car and turn it back on, the ABS light is still on and does the same...

I havent done anything on it, mainly because I dont want to spend alot of money on the wrong part to replace.

*Hints*: My brake censors are still the original since 1989, All of My brake pads and Rotors are really worn out (was gonna replace those anyways), My A.C. unit dont work, Smog guy told me my Catalytic converter almost needs replacing... I'm just typing down everything wrong with it cuz i'm not really a mechanic guy... THNX
dgreat is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-10-2009, 12:57 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1989 190E msgauvey General Mercedes-Benz 3 08-03-2009 01:58 PM
    abs malfunction 1989 300e mharness General Mercedes-Benz 0 08-01-2009 08:26 AM
    1989 190E Problem, Plz help. wakebums W201 190-Class 1 11-11-2008 02:24 PM
    Acceleration problem 1989 190E raeanncherry W201 190-Class 3 04-19-2008 01:15 AM
    1989 190e 2.6 Guest (MBNZ) W201 190-Class 1 02-19-2001 03:22 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome