1993 300SD Cranks, won't start & Glow Plug Lamp I - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-01-2009, 09:49 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1993 300SD Cranks, won't start & Glow Plug Lamp I

Hey Anyone,

I have a 1993 MB 300SD that was given to me as a gift, and I love it! It has a few issues though, like not starting right now:

1) I tried to start it today, it cranks (until I killed battery), but won't start.
- saw smoke from tailpipe, and it acted like it wanted to start but wouldn't.
- It was cold and rainy today (47 F)

Any suggestions?

2) I have noticed that since I have owned the car when I turn key all the way glow plug lamp does not come on until 30 seconds or so after it is running.

I usually wait for glow plug lamp to go out and then drive it.

Does this sound like glow plugs, or glow plug lamp relay.

Has anyone had similar problem?

I appreciate any help anyone can offer.

Thanks!

CPT Coleman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-02-2009, 11:17 AM
BenzWorld Elite
 
Date registered: Jan 2004
Vehicle: 1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Location: Ocean Isle Beach, NC
Posts: 3,467
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
Start by checking the resistance of the glow plugs. Good ones will read about 0.7 ohms. Replace any bad ones. If your battery is more than about five years old, I'd replace it too since you have drained it at least once. Probably could use a valve adjustment too.

Len
'59 220S Cabriolet - for sale - http://www.mbzponton.org/mbz220s/sellswap/car4sale.htm
'83 240D original owner 351,500 miles - for sale - http://www.benzworld.org/forums/w123...g-my-240d.html
'88 560SL 41,000 miles being parted out - https://sites.google.com/site/mercedesstuff/home
'99 E300 turbo 196,000 miles
'03 SLK320 34,500 miles
'14 Smart electric
sokoloff is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Glow plug bypass 300sd coachgeo W126 S,SE,SEC,SEL,SD,SDL Class 19 08-29-2009 11:56 AM
    93 300sd cranks but wont start apeace W140 S-Class 2 11-26-2008 09:02 PM
    Glow plug on 300sd just went away proudhon W126 S,SE,SEC,SEL,SD,SDL Class 2 03-21-2006 02:34 PM
    Need Help with Glow Plug Installation in a 1993 300D 2.5 Turbo SportsEntity W124 E,CE,D,TD Class 5 01-22-2006 11:29 PM
    1995 C280 Cranks but won't start after spark plug wire change 2000lotus W202 C-Class 1 06-18-2005 12:57 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome