electrical problem 84 380SE - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-29-2009, 11:12 AM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2005
Vehicle: 2002 E320
Location: Palm Bay Florida
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Yahoo to g3g3g3
(Thread Starter)
electrical problem 84 380SE

My windows, moonroof and wipers are inop. is there a body control module or a fuse or relay to a body control module
g3g3g3 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-29-2009, 12:17 PM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
I take it you've checked the relevant fuse(s), replaced it(them) even if they looked good just to be sure, and still no luck?

There is no BCM, but if you have numerous seemingly unrelated electrical failures, I suggest investigating for a possible ground fault.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    380SE, Fast idle and electrical drain Bob Tetrault W126 S,SE,SEC,SEL,SD,SDL Class 3 06-09-2010 02:22 PM
    380SE acceleration problem pcnj50a W126 S,SE,SEC,SEL,SD,SDL Class 31 05-12-2007 06:11 PM
    380SE starting problem jb34706 W126 S,SE,SEC,SEL,SD,SDL Class 1 03-29-2007 04:40 AM
    1984 380SE an electrical problem causing power loss?! IMnotDAVIDxnsx General Mercedes-Benz 4 09-06-2004 03:26 PM
    380SE overeating problem mapab W126 S,SE,SEC,SEL,SD,SDL Class 9 04-25-2004 04:36 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome