E class w211 instrument info display fault - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-18-2009, 03:02 PM Thread Starter
BenzWorld Junior Member
smoothhound2000's Avatar
Date registered: Mar 2009
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool E class w211 instrument info display fault

I have recently just gained a problem with my mercedes e220 model w211 55plate. The problem is with the instrument. The central circular information display and milage has become very bright. It should be black in colour with white info messages (trip, mpg, temp etc) but has now gone very light and the info is very hard to read as if to much voltage and is increasing the lcd image. When i first get in the vehicle in the morning it looks ok untill i start it up then in 5 mins its bright again. I have removed the display and reconnected it the day after but the same again. I have also tested the voltage when running and its ok around 14.3v I was wondering if there is a resistor of something in the display that is causing it or will i have to send this off for repair. I was a mastertech with saab and should understand most things you may suggest so any info would be great. Thanks
smoothhound2000 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    E class w211 instrument info display fault smoothhound2000 Audio & Telematics Forum 0 11-18-2009 02:56 PM
    Instrument backlight fault darkside V-Class 6 05-18-2009 08:23 AM
    A140 Mileage Display Unit fault km2007 W168 A-Class 3 01-23-2009 02:02 AM
    A Class mileage / service display fault Reallyfedup W168 A-Class 4 03-23-2006 05:59 AM
    [BREAKING NEWS] Official info about the W211 E-class 4matic Drew W211 E-Class 0 08-04-2003 10:25 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome