Bad Vibrations - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-11-2009, 02:11 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Bad Vibrations

Hi All
I,ve just registered to this forum as a last ditch attempt to find someone who may be able to shed some light on a vibration problem with my S350 registered in 04. It's a W220 chassis.
The vibration/shudder comes in anywhere from 65mph up and it's not rpm dependent. I've had a number of tyre changes none of which have made any difference, I've had the wheels force match balanced and more recently had them balanced on the car. Still the problem persists.
I'm leaning towards the propshaft or engine/transmission mounts. has anyone had a similar problem which has been difficult to track down. My local dealer isn't very helpful and to be honest the indy doesn't have a clue. Any thoughts would be appreciated.
Many thanks
davellew is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-11-2009, 09:38 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Welcome to the forums
I cant help, but I see you have posted your question in the w220 area
you should find answer there.
leapyfish is offline  
post #3 of 3 (permalink) Old 11-12-2009, 10:17 AM
BenzWorld Elite
F1Bobby's Avatar
Date registered: Sep 2008
Vehicle: C55 AMG
Location: People's Republic of California
Posts: 2,174
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
F1Bobby is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Help! 89 300E with bad vibrations! jerryls W124 E,CE,D,TD Class 13 09-08-2009 07:55 PM
    Bad vibrations at speeds 40 and up! sternCLK C208/A208 CLK-Class 7 12-04-2008 06:28 PM
    Bad Vibrations mrose902 W203 C-Class 0 01-14-2008 04:28 PM
    BAD Vibrations RSPINAJR W210 E-Class 28 04-19-2007 08:31 AM
    Bad Vibrations 4x4rancher G-Class 8 10-03-2005 01:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome