Jump Start Gone Bad......... - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-05-2009, 11:35 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2006
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Jump Start Gone Bad.........

I jump started my 92 500 R129. I connected the terminals WRONG (pos to neg). The battery on the other car started to smoke. I discconected the cables. I jump started my R129 the propper way, and my instrument cluster was not working. I replaced the fuse and everything works except the MPG guage.

Now the car is hard to start, idles very rough, sometimes turns off. I can drive it, but it feels like its driving on 4 cylinders NO POWER. Missfiers bad.

Please any info will help. I have replaced the battery but still the same problem.
s500newb is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-06-2009, 01:33 AM
BenzWorld Junior Member
 
gamble's Avatar
 
Date registered: Oct 2009
Vehicle: 420sel
Location: cali
Posts: 40
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
jumped....

first of all, welcome.!
second, next time you jump start a car, put the negative cable of the car that needs jumped on a part of the engine or something that is grounded to the battery. do not put the negative directly to the terminal. doing so could possibly save $$$ and time by protecting your electrical components from frying .... or something along those lines. i just know that its safer.
third, what probably happened was what i said above. it could be a problem with a relay, sensor or computer... you might want to do a search on the over voltage protection (ovp) relay. im not sure... but if you do a search im sure someones done or had the same kind of problem.
best of luck !!!

Gamble says... does it really matter.?.?.?
gamble is offline  
post #3 of 3 (permalink) Old 11-06-2009, 10:55 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
REAL BAD IDLE AFTER BATTERY JUMP slickqrickq R170 SLK-Class 22 06-30-2009 08:24 AM
how to jump start?? PLEASE HELP grider G-Class 3 05-06-2009 06:19 PM
How to jump start? beastia R129 SL-Class 16 12-24-2007 11:56 AM
AFTER JUMP START? FASTRMK700 W202 C-Class 3 10-09-2007 12:49 PM
Jump Start? FASTRMK700 W202 C-Class 2 10-08-2007 11:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome