faulty gauge cluster - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-02-2009, 04:28 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
faulty gauge cluster

Hey I was wondering if any one has had this problem. i have a 97 c280 and my gauges work about 1 out of every 5 times i use the car. its not like the sticky gauges the needles dont have any little posts to sit on and they never pop on while your driving. when you start the car they either work or they dont. thanks!
mtscorvette is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-03-2009, 05:16 PM
Supporting Vendor
 
FCP Euro's Avatar
 
Date registered: Jul 2008
Posts: 697
Mentioned: 0 Post(s)
Quoted: 22 Post(s)
Sounds like you have a short in the wiring. I would pull the dash and the gauge cluster to see if there are any loose connections and also make sure that the wiring is still in good shape.


Quality & Service, Guaranteed for Life
FCP Euro - OEM & Genuine European Auto Parts Online
FCP Euro is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Do You Have A Faulty Fuel Gauge? Yazovets! W164 M-Class 14 03-21-2009 01:58 PM
    Faulty fuel gauge, or not? MBeige W124 E,CE,D,TD Class 5 04-30-2007 07:18 PM
    Problems fitting 500 fuel gauge-oil pres'-water temp gauge cluster to 560 clocks mutley666 W126 S,SE,SEC,SEL,SD,SDL Class 2 10-10-2005 10:03 AM
    Faulty outside temp gauge Iwan W203 C-Class 2 11-01-2003 11:07 PM
    Faulty gauge cluster in 83 300D SHIFT_diesel W123 E,CE,D,CD,TD,TE Class 4 09-26-2003 10:50 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome