2001 ML320 BAS/ESP, ETS,ABS, brake warning, check engine signs all on! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-30-2009, 02:48 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool 2001 ML320 BAS/ESP, ETS,ABS, brake warning, check engine signs all on!

Someone with same experience please help me!
My 2001 ML320 had check engine light for months which I ignored.
2 months and 2000 miles ago I had front brake pads and rotors replaced at a shop (OEM ones).
Since 1 month ago occasionally in the morning when it's chilly here in San Diego, BAS/ESP,ETS,ABS,Brake warning sign and red Brake sign illuminate all at once with beeping sound upon ignition or 5-10 seconds after ignition. Car shakes upon gear change. When I drive on, speedometer stays at 0, although tacometer works and the car feels like scratching on the ground with increased friction, as if I had not released the brake.
This is not happening when I start the car later in the day when it's warmer. The next morning it recurs.
As you might have noticed, I am a novice. Someone said it's brake switch. others said it's speed sensor. Stealership said ESP control unit, traction unit. They said ESP control unit is faulting and ESP control unit connector has corrosion, quote for replacement is $3319.
I know similar problems were posted here many, many times but wondering if someone had exactly same problem I have and can share how they handled it. Thanks!

Last edited by CWLEE; 10-30-2009 at 05:30 PM.
CWLEE is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-30-2009, 05:40 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Did the stealer hook it up to the Mercedes SDS system to arrive at this dianosis? If so, it's a pretty sure thing, although nothing is perfect.

The first thing I would do is check your battery. Not only is that inexpensive and easy to do, but there have been numerous complaints of this general nature (several warning lights on simultaneously) and a few times the problem was low voltage due to a bad battery.

The shaking on shifts and the scratching are probably something else, and I'm not a wizard when it comes to self repair either. The speedometer is a but quizzical but that might be due to an electrical issue too.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 4 (permalink) Old 10-30-2009, 11:45 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I am not sure if they hooked with SDS system but

The paper says I requested MPI World Class Inspection. Should I ask them if they did SDS inspection, you think?
It said " recommend new control unit and further advise" so I guess they just want to try this out and see if this fixes the problem? And it will cost me over $3000!
Thank you for the reply BTW.
Can anyone share any other thoughts?
CWLEE is offline  
post #4 of 4 (permalink) Old 10-31-2009, 07:35 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I don't know what MPI World Class means, but any competant dealer would have used the Star (SDS) system. It wouldn't hurt to ask them what they did. They might be just replacing parts, it's hard to tell. Also, find the correct ML-Class forum and ask your questions there too.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Back Again BAS/ETS ESP ABS Lights on...and check Engine vancevirgil W163 M-Class 7 12-16-2011 01:21 AM
    BAS/ESP+ETS+ABS+Brake-Pads+Brake steffen.gutmann W163 M-Class 17 09-13-2009 11:32 AM
    ML 430 - 2000 - I NEED HELP!My BAS/ESP, ETS(ABS) and (Check Engine) lights come on. T nhaile W163 M-Class 3 09-19-2006 09:20 PM
    01 ML320 ABS/ETS/BAS-ESP Lights On hlai W163 M-Class 6 06-21-2006 06:45 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome