1991 300e Stalls then wont start till after 20 trys - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-24-2009, 09:06 AM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2009
Vehicle: 1991 300 e 94000 miles 2.6
Location: long island suffolk
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 1991 300e Stalls then wont start till after 20 trys

I have a 1991 300e 2.6 engine. The car has been to the mechanic twice this past two weeks. I am frustrated.
The problem: The car starts up fine, runs good then after I shut it off after going about 4 miles , the car wouldnt start. I tried turning it over but it turned then wouldnt start. i keep trying this. it sounded like the battery was dying. Finally it turned over and I had to keep my foot on the brake and the gas to keep her running. if not she would sputter and try to die. Got her home. Went to start up next day and she started right up but sputtered. Took her to a local KING BEAR. I know big mistake. He had the car a few days said he put the car on a fuel injetor cleaning machine and added chemicals. Said he did it about 4 times. Picked up car and she ran better. Drove her a few dyas and started stalling again. Brought it back. they put it on the computer and said everything checks out ok. mechanic on the side said he thinks it is ignition related because above 2o mph runs excellent. but computer states everything ok. five more days later and supposedly another 5 times on the fuel injector machine said come pick up. Bill said clean fuel system and injectors throttle body egr passages. He said plugs and cap looked good. Ran good. Drove it 2 days went about 17 miles and car began sputtering and then died. would not start. turned key and would turn but almost like the battery was dead. Finally after getting her sated 30 minutes later after turning ignition over about 20 times. she started ran real rough. Had to keep foot on brake and gas. Drove for 1 mile back to house and finally took foot off brake and car idled. put it in gear and ran fine no hesitation or sputtering. I am baffled. Dont want to bring it back to same mechanic. Spoent 5oo bucks there and still not right. I have seen threads for ovp, mas relay, and crank positon sensor. What can be wrong. Wher edo I start. Oh he also did not want to change the fuel filter becasue he said the lines are copletely rusted and he didnt want to open a can of worms trying to get it off. I want to sell the car but won't in this condition. Has only 94000 miles on her. He also said the gas smelled bad the first time in. last time i picked it up he had run it down from about 1/4 tank to 1/8 of tank. After picking it up I have filled it with super. and have only gone 17 miles. PLEASE HELP.
91 300e ny is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Takes two tries to start i6h000 W124 E,CE,D,TD Class 8 12-27-2009 09:34 PM
    1987 560sl. Sudden stalls/wont start warm RBelniak R/C107 SL/SLC Class 11 07-14-2009 01:08 PM
    7 Trys for a Start schwalbe181 W201 190-Class 19 12-21-2008 10:19 AM
    1991 300te stalls and wont start when warm. nnooee W124 E,CE,D,TD Class 1 08-18-2008 06:58 AM
    1991 300E wont start giles117 W124 E,CE,D,TD Class 16 07-15-2006 12:44 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome