s430 instrument cluster not working - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-15-2009, 05:26 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
s430 instrument cluster not working

i have an 01 s430, the battery died a a couple weeks ago, had it sent to a local garage, they replaced the battery for me, but the instrument cluster does not work, my signals dont work, but they all light up when i arm and disarm or when my lights turn on, the parking lights are on... heard this might be a common issue...anyone?
kalpesh.k.patel is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-15-2009, 07:23 PM
BenzWorld Elite
 
Date registered: Feb 2008
Vehicle: 2004 W220 (S430) ; 2001 R129 (SL500) Sport
Location: Alabama Gulf Coast--formerly Charlottesville, VA
Posts: 1,335
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Try the W220 forum (look down the home page to the sedans, then scroll down to the W220 forum); you'll have more luck asking your questions in a room full of people who own the same car you do.

Also, please fill out your profile--especially where you are. Sometimes, people can recommend a garage not far from you. I surmise you are not in the United States, but I could easily be wrong. If not, there are likely to be W220 owners in your country who may be able to suggest a garage.

I don't know the answer to your question even though I own a W220. The forum is your best bet.

Good luck.

"Don't pick a fight with an old man. If he is too old to fight, he'll just kill you."--John Steinbeck
DrJfrmLA is offline  
post #3 of 3 (permalink) Old 10-15-2009, 09:02 PM
~BANNED~
 
Date registered: Sep 2004
Vehicle: 1996 S600 1991 560SEL 1995 S500 2009 S550
Location: Encino, California
Posts: 986
Mentioned: 1 Post(s)
Quoted: 0 Post(s)
there was an official recall and free replacement of the whole cluster, ask your dealer about it.
cool is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
New s430 owner, need assistance with instrument cluster s430owna W220 S-Class 13 09-22-2009 12:42 PM
Instrument cluster not working kthompson W140 S-Class 8 06-21-2009 05:00 AM
Instrument cluster - all needs on zero, nothing working akoch R129 SL-Class 7 04-01-2007 12:29 PM
s430 instrument cluster gfy320 W220 S-Class 1 09-01-2005 03:05 AM
2001 Mercedes S-class S430 Instrument Cluster FOR SALE atikovi For Sale/Wanted/Trade/Giveaway 0 07-16-2005 08:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome