vito has misfire and white smoke - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-10-2009, 04:11 PM Thread Starter
BenzWorld Junior Member
Date registered: Oct 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool vito has misfire and white smoke

Hi Im new to this site and its great to have found it
I have a turquoise vito with the windows in the side doors 2 seats in the back and amg rims. its perfect for what I need for work and the family, and I love it.
My van was running fine (108cdi) apart from the fact it was losing water from the waterpump. I thought i would tackle this job, but after having a go in the rain i decided it was not for me. I took the van to a friend of a friends garage and they did the job for £90 (was ok with that) On collection of my van it now has a misfire and is pumping out white smoke, It is bad on tickover and at low revs, it sort of clears at higher revs. Engine is making usual nasty noises that come with this. Doing the job I know they had to remove the mount and drop the engine, my theory is that a pipe or wire may be damaged? as it was running fine when i turned it off, and a smokey pile of .... when they started it up!
freshwater21 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-10-2009, 11:58 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
post #3 of 3 (permalink) Old 10-11-2009, 01:01 AM
BenzWorld Junior Member
Date registered: Oct 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
white smoke

I had this happen to me on my 1975 280, If I recall right, the tran. fluid is making the white smoke, there is a line going maybe from carb down to the tran, there is a one way check valve there, I think its bad, been few yr.s ago,
atms is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    #8 Cylinder misfire with white smoke and oil leak SMotors W221 S-Class 10 05-30-2008 03:02 AM
    White Smoke ? ML 320 CDI W164 M-Class 8 12-18-2007 01:39 PM
    310 Sprinter, Blue Smoke & Misfire 16v205 W901-905 Sprinter 2 12-03-2007 05:01 PM
    White Smoke ?? ML 320 CDI W163 M-Class 9 11-24-2007 10:03 AM
    E320 Misfire/Fuel smoke at idle & steady throttle Guest (MBNZ) W124 E,CE,D,TD Class 4 12-20-2001 07:13 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome