Mercedes ML320 wont start, SMS Airbag lights on - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-08-2009, 11:51 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2009
Vehicle: ML320 Year: 2000
Location: CA, USA
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes ML320 wont start, SMS Airbag lights on

Hi - I have a 2000 ML320. Same problem as others have had (athensdan and others: http://www.benzworld.org/forums/w163...ml#post3318220.
Always the same symptoms....will not turn over, remote alarm does not work, overhead dome lights do not work, but other things do work (radio, headlights, electric windows, seat heat, etc). Does not even attempt to turn over and the only idiot light are SMS and Air Bag.
I saw a post somewhere where someone had taken the fuze box (well, the box with connectors and connectors) out of its outer fuse box container and the jolt got everything working again. That worked for me too. I replaced the fuse box fan which had failed (which probably means the damage has been done), but I'm still getting the same problem every so often. Seems to be related to the aircon. When I press the aircon switch that's when everything dies. Waiting 15-30 mins and jiggling the fuse box brings everything back too life. Seems like something's overheating (AAM?) and needs time to cool off. Maybe the Aircon is just the trigger as it takes a large electric load when it kicks in. Any new ideas from anyone?
petergusa is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-08-2009, 10:02 PM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1999 ML320 won't start only SMS and AB lights John Bay Area W163 M-Class 110 09-15-2014 02:54 PM
MERCEDES E 220 WONT START AT ALL, BUT ALL THE LIGHTS AND BATERY IS OK! SajidM W210 E-Class 5 06-04-2009 08:39 AM
another ML320 that wont start, please help :) bossbenzo W163 M-Class 12 06-04-2009 04:44 AM
Lights come on but wont start.... 240DZL W123 E,CE,D,CD,TD,TE Class 11 03-08-2006 05:21 PM
wont start, crazy lights bigmoo W163 M-Class 2 02-27-2006 06:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome