98 E430 Weird Electrical Problem - Help! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-08-2009, 09:26 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
98 E430 Weird Electrical Problem - Help!

This is driving me crazy. Randomly, different electrical things stop working (power windows & seats, power sunroof, etc.). They fail independantly at different times (except for things that are on the same circuit, i.e driver power window and power seat). It has even happended with the wipers and the trunk lid release, just not as frequent as the windows/seats. If I pull out the fuse for the circuit that no longer works and put the same one back in, everything on that circuit will start working fine (at least for a few days). Pulling out and putting back in the same fuse will only fix the problem if the ignition is on, it will not work with the key off. Removing the battery terminal and replacing it after a few seconds will also fix the problem. A brand new battery did not keep the problem from resurfacing. My Benz mechanic has no idea. Help!
tommy_ace is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-08-2009, 07:24 PM
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sounds like a grounding issue within the car. Something is shorting on the body or frame.
mr.xpowerseller is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Weird Electrical Problem. HELP!! ahermster W203 C-Class 10 01-03-2009 05:48 PM
    Weird Electrical Problem busker W123 E,CE,D,CD,TD,TE Class 7 04-13-2008 12:53 PM
    weird electrical problem metricstar W124 E,CE,D,TD Class 5 11-12-2007 10:25 AM
    HELP: weird electrical problem lovemercedes2.8 W124 E,CE,D,TD Class 1 12-27-2005 07:36 PM
    Weird electrical problem Linc Fish W126 S,SE,SEC,SEL,SD,SDL Class 4 02-06-2004 12:53 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome