my ML heater has no heat - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-07-2009, 09:47 PM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool my ML heater has no heat

Hi- I have a 98 ML320 and the heater/defrost just blows cold. Heard some clicking in the blower motor, so I changed the cabin filter- it was way dirty, but still no heat. I checked the top and bottom radiator hoses as well as the heater hoses in and out of the heater core--all hot. I've heard there is a blend door actustor that fails sometimes. Started to remove the glove box to 'look' at it but got cold feet. Any suggestions?
rickyb is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-08-2009, 11:22 AM
BenzWorld Elite
 
leapyfish's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 SLK230 210,xxx Miles
Posts: 7,685
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
leapyfish is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
No heat, Air in heater tube??? cal1 R230 SL-Class 1 10-23-2008 06:57 AM
Seat heater lights up but no heat seki W220 S-Class 1 01-11-2007 04:22 AM
Seat heater lights up but heat seki W220 S-Class 0 01-10-2007 10:16 PM
leak heat exchanger (radiator / cabin heater) SL500>>> R129 SL-Class 3 01-19-2006 10:46 AM
2001 C240 HEATER FLOOR HEAT MAX BLAKELY W203 C-Class 0 02-20-2004 05:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome