2002 ML500 steering issues - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-07-2009, 10:51 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 2002 ML500 steering issues

Vehicle tends to pull harder left or right whenever small steering corrections are input to compensate for road curvature. Feels like something is shaky in the steering, but investigation finds nothing major. Needs constant correcting. No fun to drive.

Front end seems tight. No leaks. Less than 3 thousand miles on the tires. One mechanic's diagnosis points to power steering pump problems, another says it's possibly the rack and pinion. I don't want to pay for replacing part after part.

Also, steering does not recover out of turns. Must manually crank back to center, even at speed.
orionrain is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-07-2009, 11:23 AM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    wide tires (275x55 R17's) on ML500 and ML430 issues? guy W163 M-Class 18 09-13-2011 02:17 PM
    ML500 Mod nightmare, Kleemann install issues and more RUEY220 W163 M-Class 7 04-08-2010 01:29 PM
    Headlamp / high beam / shaft issues ML500 (2002) Chi_ml500 W163 M-Class 4 01-05-2009 02:38 PM
    Ml500 CD Changer issues gdrysdale Audio & Telematics Forum 2 10-28-2007 10:06 AM
    Need Information on Two ML500 Issues Darkmann W163 M-Class 7 11-22-2005 05:10 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome