confused and desperate - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-03-2009, 06:33 PM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post confused and desperate

I have a 1987 300 E and it has been sitting in the drive way for about 1 1/2 years and I felt a need to try to start it recently. The gas in it was quite foul-smelling so I drained the tank and put in fresh gas after turning the ignition switch a few times to see if I could hear the with the fuel pump and after not hearing the fuel pump I jumped it with a battery and it was still dead, after replacing the fuel pump I noticed rust coming out of the gas tank so I drained the tank and took it out. I ran a hose onto the back of the fuel pump and put a fresh 10 gallon tank of gas above the fuel pump on the trunk of the car then I turned on the ignition a few times to prime the fuel pump but the car would never start. I took a few line going into the fuel distributor and pressure tested the fuel line and my meter showed well over 100 psi. I tested all of the injectors by placing them all in little jars to see if they sprayed correctly and a few of them did not spray and just dribbled, so I decided to replace all of the injectors with new injectors and after doing that I tried to start the car with no luck. The car will start if I pour gas or starter fluid into the throttle body and the car will run for about one minute and shut off after it has used up all of the gas that I poured into the throttle body. I know that I'm getting over 100 psi coming from the fuel pump before it gets to the fuel distributor , I took out one of the new fuel injectors and placed a hose and clamp onto that injector line to do a pressure test and the pressure measured out to be around 45 psi can anyone tell me a solution for my problem or tell me what the problem is. Thank you desperate and confused
mcw11 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-04-2009, 02:04 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Desperate for help Otis Day The Discount Tire Direct Tire, Wheel, Brake & Suspension 2 03-28-2008 05:12 AM
    Confession of a Neocon (Newly Confused) I am confused and I want to know....... Jakarta Expat Off-Topic 52 04-13-2007 08:32 AM
    Getting desperate for one of these... ~BenzBoy~420-SEL~ W126 S,SE,SEC,SEL,SD,SDL Class 5 04-07-2006 03:25 PM
    Getting desperate for one of these... ~BenzBoy~420-SEL~ For Sale/Wanted/Trade/Giveaway 7 04-07-2006 01:54 PM
    Please Help, I'm desperate!!!! Zlatko General Mercedes-Benz 2 06-19-2005 11:06 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome