99 E320 ME Unit - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-23-2009, 11:23 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 99 E320 ME Unit

Hello all,

I love this car.... but it's testing me. I just got my car service and the very same day it stopped. No signs or anything. I was told that it was the ME Unit $$$. Could it be anything else? Any suggestions or similar problems? Also, can anyone recommend someone that actually repairs and provides good service in Charleston SC?
blkbrybrwnsuga is offline  
Sponsored Links
post #2 of 2 (permalink) Old 09-23-2009, 01:29 PM
BenzWorld Elite
leapyfish's Avatar
Date registered: Apr 2008
Vehicle: 1998 SLK230 199,xxx Miles
Posts: 7,675
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
leapyfish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    HELP!!! 95 E320, CC/ISC Unit location? GA_E320 W124 E,CE,D,TD Class 7 02-14-2011 08:20 AM
    dvd unit in a 2000 E320 binelus Audio & Telematics Forum 3 08-07-2005 02:33 PM
    E320 POWER STEERING UNIT ALVDON For Sale/Wanted/Trade/Giveaway 0 05-21-2005 01:51 AM
    E320 AC UNIT PROBLEM DADARKPRINCE W210 E-Class 4 04-19-2005 04:37 PM
    How to replace Bose head unit?? (99 E320) dstorfer Audio & Telematics Forum 4 03-19-2004 07:05 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome