2001 CLK320 Convertible Transmission Problem - won't shift - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-21-2009, 07:37 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2001 CLK 320 Convertible
Location: Suburbs of Philadelphia, PA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Post 2001 CLK320 Convertible Transmission Problem - won't shift

Hello all,

I have a 2001 CLK 320 Convertible with 98k miles.

The car has been nothing but phenomenal, no major problems ever. Until Last Week.

I started the car as usual and tried to back it out, the engine was running about 1100 RPM and it backed out very rough and fast and then I tried to put in "D" and it jumped but I drove it through the neighborhood and noticed that it did not shift.

I noticed that the digital display does not show "D" Or "R" or anything else either... I can only put it in D, R & Park. I am not sure what gear it is stuck in "D" but pretty sure it is first gear...

I read that sometimes spilling water on console will cause same type problems but there was no spillage.

I cannot check the transmission fluid and not sure what is wrong...

BTW, the "check engine" light is on but it was on before the problem and that code was read and I had to get a new MAF sensor which I was going to do when this happened.

Anything I can try before I take it to the dealer?

Thanks for reading.

Q
qfard is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-21-2009, 07:48 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Welcome aboard, please click user cp and add vehicle and location info to your profile.

This is the general forum, but since your Q relates to a specific model, you're likely to get better info in the W208 forum that is specific to your car.

Bad MAF? Change it. NOW. Ignoring it can destroy your cats and kill your O2 sensors...and if it bad enough it can send signals that will disrupt shifting.

Worse, driving around with the CEL on is the same thing as removing the bulb. You may have 6 or 8 codes stored in there, but there is no way to know since the light can't exactly come on again, right?

Go get the codes read, but first order a new MAF, autohausaz.com has them on sale with free shipping.

It is possible the contacts in the shift module are just dirty...but really you have a computer that may be trying to tell you something, so may as well let it instead of spending lots of time and money guessing.

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 6 (permalink) Old 09-21-2009, 08:09 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2001 CLK 320 Convertible
Location: Suburbs of Philadelphia, PA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
gregs210 - thanks for the points and advise.

I had the MAF cleaned and the code reset (my friend is Saab mechanic)... and CEL went away...

Months later,the CEL returned and he re-read the same code... cleaned it again but it CEL stayed...

I don't drive this car that often, maybe 100 miles later the transmission started...

I updated my personal stuff and will order the MAF from the site you recommended.

Thanks again for taking time to reply.

Q
qfard is offline  
post #4 of 6 (permalink) Old 09-22-2009, 12:12 AM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
You probably know this already, but you can change the MAF yourself in about five minutes with only a flat-blade screwdriver. The code will clear by itself.

Depending on the codes you get, the trans issue may be the well-known leaky adapter/connector infiltrating the TCM. Lots of good info in the forums.

Good luck!

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #5 of 6 (permalink) Old 09-22-2009, 01:00 AM
BenzWorld Junior Member
 
guardrail's Avatar
 
Date registered: Sep 2006
Vehicle: 2005 CL65 AMG
Location: Olyphant, Pa.
Posts: 38
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sounds like it's in fail safe mode. Once you fix the problem that's causing the CEL, and clear the codes It should start shifting properly
guardrail is offline  
post #6 of 6 (permalink) Old 09-24-2009, 05:14 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2001 CLK 320 Convertible
Location: Suburbs of Philadelphia, PA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
I got the MAF sensor today in mail and replaced... disconnected the battery for a minute... the CEL was gone but still won't shift...

after few start and stop, the CEL was back... after another battery disconnect was gone again... is there transmission relay and/or sensor I can try?

Tried the some "trans reset" procedure... no good...

any help?
qfard is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2001 SLK320 Convertible Hardtop Problem the_grimace R170 SLK-Class 10 10-07-2008 12:54 PM
    I GOT AN 04 CLK320 W209 CONVERTIBLE OVER THE R171 SLK350 & SLK280 CONVERTIBLE !!!!!!! max_benz R171 SLK-Class 5 10-24-2007 01:18 AM
    What's Up with This....1999 SL500 transmission shift problem Scott M R129 SL-Class 11 09-28-2007 02:41 PM
    Transmission shift problem cmeblaisen W210 E-Class 6 06-22-2007 02:32 PM
    2001 SLK - Spilling liquids into shift lever shuts down engine and/or transmission mbslk350 R170 SLK-Class 22 04-06-2006 08:09 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome